summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Heinemann2016-09-21 13:26:21 +0200
committerStefan Heinemann2016-09-21 13:26:21 +0200
commit305175e48dc4b60f71f50835c5f67182fc928380 (patch)
tree395fd1f880fab8496c2b97b6d728351479693b7c
downloadaur-305175e48dc4b60f71f50835c5f67182fc928380.tar.gz
First commit of the pockyt app - a python client for pocket
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3cce8414dd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pockyt
+ pkgdesc = automate and manage your pocket collection
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/arvindch/pockyt
+ arch = any
+ license = GPLv3+
+ makedepends = python3
+ depends = python
+ source = https://pypi.python.org/packages/1a/e0/a47f82100e5035bb9b22b952cd699706101e815cae01788ea6d533849641/pockyt-1.0.zip
+ md5sums = b714f28e3a4fa5a536a45586ee73b11d
+
+pkgname = pockyt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf12edb716e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Heinemann <stefan.heinemann@codedump.ch>
+
+pkgname=pockyt
+pkgver=1.0
+pkgrel=1
+pkgdesc="automate and manage your pocket collection"
+url="https://github.com/arvindch/pockyt"
+depends=('python' )
+makedepends=('python3' )
+license=('GPLv3+')
+arch=('any')
+source=('https://pypi.python.org/packages/1a/e0/a47f82100e5035bb9b22b952cd699706101e815cae01788ea6d533849641/pockyt-1.0.zip')
+md5sums=('b714f28e3a4fa5a536a45586ee73b11d')
+
+build() {
+ cd $srcdir/pockyt-1.0
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/pockyt-1.0
+ python setup.py install --root="$pkgdir" --optimize=1
+}