summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2017-04-12 22:40:36 +0200
committerspider-mario2017-04-12 22:40:36 +0200
commitc98e9a8ca1f13e0efa3e261b8888b982e761ce61 (patch)
treefa5519a63b74af4f8070653ed133314be4495f74
parent06d6ae80cc0135381dcc5c9a63c33b608387aac6 (diff)
downloadaur-c98e9a8ca1f13e0efa3e261b8888b982e761ce61.tar.gz
0.14
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d3c971c5f0c..15599f836567 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 9 15:20:30 UTC 2016
+# Wed Apr 12 20:40:03 UTC 2017
pkgbase = pocl
pkgdesc = Portable OpenCL is an open-source implementation of OpenCL which can be easily adapted for new targets
- pkgver = 0.13
- pkgrel = 1
+ pkgver = 0.14
+ pkgrel = 2
url = http://portablecl.org/
arch = i686
arch = x86_64
@@ -12,12 +12,12 @@ pkgbase = pocl
makedepends = llvm
makedepends = ocl-icd
depends = clang
- depends = libcl
depends = hwloc
depends = libltdl
depends = opencl-headers
- source = http://pocl.sourceforge.net/downloads/pocl-0.13.tar.gz
- sha512sums = 1892a6167bb5d48acaa79de4a9a76355c624e01a3bec31599947d6972eddcfd0b7523d61a3bd08018a30e34ab5a1b225a7ca2feaa2c2f6fcf03403fb887a6c0d
+ depends = opencl-icd-loader
+ source = http://pocl.sourceforge.net/downloads/pocl-0.14.tar.gz
+ sha512sums = 36bf41222315e13bac6c37cc942b9c09e22af0374abf63052fa8deb1ffe383da0ed9b5dc3548844d52749642d0b1288af5e0128e8dd4deb38e70128adb28c066
pkgname = pocl
diff --git a/PKGBUILD b/PKGBUILD
index 066b6934a1c6..737c84c4fd56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
# Contributor: fabien Cellier <fabien.cellier@gmail.com>
pkgname=pocl
-pkgver=0.13
-pkgrel=1
+pkgver=0.14
+pkgrel=2
pkgdesc="Portable OpenCL is an open-source implementation of OpenCL which can be easily adapted for new targets"
arch=('i686' 'x86_64')
url="http://portablecl.org/"
license=('GPL')
-depends=('clang' 'libcl' 'hwloc' 'libltdl' 'opencl-headers')
+depends=('clang' 'hwloc' 'libltdl' 'opencl-headers' 'opencl-icd-loader')
source=("http://pocl.sourceforge.net/downloads/$pkgname-$pkgver.tar.gz")
makedepends=('cmake' 'llvm' 'ocl-icd')
-sha512sums=('1892a6167bb5d48acaa79de4a9a76355c624e01a3bec31599947d6972eddcfd0b7523d61a3bd08018a30e34ab5a1b225a7ca2feaa2c2f6fcf03403fb887a6c0d')
+sha512sums=('36bf41222315e13bac6c37cc942b9c09e22af0374abf63052fa8deb1ffe383da0ed9b5dc3548844d52749642d0b1288af5e0128e8dd4deb38e70128adb28c066')
build() {
mkdir -p build
@@ -30,5 +30,4 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir"/ install
- chmod +x "$pkgdir"/usr/bin/pocl-standalone
}