summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Ricci2024-01-23 16:40:27 +0100
committerViktor Ricci2024-01-23 16:40:27 +0100
commitd2e7dd6587459b08d4c30f710e828437755bc710 (patch)
treed9519471e854b65ef0429bab15d44ef6718860d0
downloadaur-d2e7dd6587459b08d4c30f710e828437755bc710.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ef40d5b1ae2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = poddl-git
+ pkgdesc = Podcast Downloader - Download all podcasts / episodes from an RSS-feed
+ pkgver = 2023.10.16
+ pkgrel = 1
+ url = https://github.com/freshe/poddl
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ depends = curl
+ provides = poddl
+ conflicts = poddl
+ source = git+https://github.com/freshe/poddl.git
+ b2sums = SKIP
+
+pkgname = poddl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5ab54970392
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Viktor Ricci <ricci@primateer.de>
+
+pkgname=('poddl-git')
+_gitname=('poddl')
+pkgver=2023.10.16
+pkgrel=1
+pkgdesc="Podcast Downloader - Download all podcasts / episodes from an RSS-feed"
+url="https://github.com/freshe/poddl"
+license=('MIT')
+source=('git+https://github.com/freshe/poddl.git')
+b2sums=('SKIP')
+arch=('x86_64')
+depends=('gcc-libs' 'glibc' 'curl')
+makedepends=('git')
+checkdepends=()
+provides=('poddl')
+conflicts=('poddl')
+_sample_rss='https://gist.githubusercontent.com/rodydavis/d0cb7a53d8deb42e92ae803a9dd48dbc/raw/94c3a5bef2c662122d3663e0c27e7db2d7fe2cd7/podcast_rss_feed.xml'
+
+pkgver(){
+ cd "${srcdir}/${_gitname}"
+ grep -hoP '#define VERSION "\K[^"]+' *.cpp *.hpp
+}
+
+build(){
+ cd "${srcdir}/${_gitname}"
+ g++ *.cpp -O2 -std=c++11 -lcurl -o "${_gitname}"
+}
+
+check(){
+ cd "${srcdir}/${_gitname}"
+ ./"${_gitname}" "${_sample_rss}" -l
+}
+
+package(){
+ cd "${srcdir}/${_gitname}"
+ install -Dm755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}