summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-18 18:12:55 +0800
committerzxp198210052024-03-18 18:12:55 +0800
commit2c8ed7087799c35c7523a08c5a2824c1e9041eeb (patch)
tree353001f7037547891f75b7b877f15f297f3686a5
parent58b8a5e27b3200d9b4919c567a38159d14008eb9 (diff)
downloadaur-2c8ed7087799c35c7523a08c5a2824c1e9041eeb.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--poddycast.sh8
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1771bc2e2ee..08923d319d91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = poddycast-bin
pkgdesc = A Podcast app made with Electron, lots of ❤️ and ☕️
pkgver = 0.11.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/MrChuckomo/poddycast
arch = aarch64
arch = armv7h
@@ -14,7 +14,7 @@ pkgbase = poddycast-bin
provides = poddycast=0.11.0
conflicts = poddycast
source = poddycast.sh
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = poddycast-0.11.0-aarch64.zip::https://github.com/MrChuckomo/poddycast/releases/download/v0.11.0/Poddycast-linux-arm64.zip
sha256sums_aarch64 = 35f4d7a1a43c950a4eb4a242eda4f9442539467364d62aac3c74d837db4983ef
source_armv7h = poddycast-0.11.0-armv7h.zip::https://github.com/MrChuckomo/poddycast/releases/download/v0.11.0/Poddycast-linux-armv7l.zip
diff --git a/PKGBUILD b/PKGBUILD
index 358971682644..f6663b1b0139 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=poddycast-bin
_pkgname=Poddycast
pkgver=0.11.0
_electronversion=22
-pkgrel=5
+pkgrel=6
pkgdesc="A Podcast app made with Electron, lots of ❤️ and ☕️"
arch=(
"aarch64"
@@ -27,7 +27,7 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${url}/releases/download
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.zip::${url}/releases/download/v${pkgver}/Poddycast-linux-armv7l.zip")
source_i686=("${pkgname%-bin}-${pkgver}-i686.zip::${url}/releases/download/v${pkgver}/Poddycast-linux-ia32.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/Poddycast-linux-x64.zip")
-sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('35f4d7a1a43c950a4eb4a242eda4f9442539467364d62aac3c74d837db4983ef')
sha256sums_armv7h=('a29309aa3b2e9c6507404c0d9298350fbe93ca88a6ca13b117782aeb0db3a167')
sha256sums_x86_64=('1b5e2ff12ff8af90a021e70ed8e1f8c2439a16488476252e3b078b9cac4da8a9')
@@ -35,6 +35,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --categories="AudioVideo" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
}
diff --git a/poddycast.sh b/poddycast.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/poddycast.sh
+++ b/poddycast.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file