summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-13 18:10:25 +0800
committerzxp198210052023-12-13 18:10:25 +0800
commitdfbc87b01945edf0057c1c73499238b019e23cad (patch)
treeed7c2980ee76a9f92515d44ea0537d21def08be9
parent2fb8eca5970de66b803526c5dbf7999f4820814f (diff)
downloadaur-dfbc87b01945edf0057c1c73499238b019e23cad.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--poddycast.sh17
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e3055296a3e..203f50dc6da0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = poddycast-bin
pkgdesc = A Podcast app made with Electron, lots of ❤️ and ☕️
pkgver = 0.11.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MrChuckomo/poddycast
arch = aarch64
arch = armv7h
+ arch = i686
arch = x86_64
license = GPL3
makedepends = gendesk
- depends = bash
depends = electron22
provides = poddycast=0.11.0
conflicts = poddycast
source = poddycast.sh
- sha256sums = a00d29a2264aa2fa31e3ddecc52643a3924fcda917e25953c1ba73fbd55a952c
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
source_aarch64 = poddycast-0.11.0-aarch64.zip::https://github.com/MrChuckomo/poddycast/releases/download/v0.11.0/Poddycast-linux-arm64.zip
sha256sums_aarch64 = 35f4d7a1a43c950a4eb4a242eda4f9442539467364d62aac3c74d837db4983ef
source_armv7h = poddycast-0.11.0-armv7h.zip::https://github.com/MrChuckomo/poddycast/releases/download/v0.11.0/Poddycast-linux-armv7l.zip
sha256sums_armv7h = a29309aa3b2e9c6507404c0d9298350fbe93ca88a6ca13b117782aeb0db3a167
+ source_i686 = poddycast-0.11.0-i686.zip::https://github.com/MrChuckomo/poddycast/releases/download/v0.11.0/Poddycast-linux-ia32.zip
source_x86_64 = poddycast-0.11.0-x86_64.zip::https://github.com/MrChuckomo/poddycast/releases/download/v0.11.0/Poddycast-linux-x64.zip
sha256sums_x86_64 = 1b5e2ff12ff8af90a021e70ed8e1f8c2439a16488476252e3b078b9cac4da8a9
diff --git a/PKGBUILD b/PKGBUILD
index 0c6434713f18..65665fd57156 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,13 @@
pkgname=poddycast-bin
_pkgname=Poddycast
pkgver=0.11.0
-pkgrel=2
+_electronversion=22
+pkgrel=3
pkgdesc="A Podcast app made with Electron, lots of ❤️ and ☕️"
arch=(
"aarch64"
"armv7h"
+ "i686"
"x86_64"
)
url="https://github.com/MrChuckomo/poddycast"
@@ -14,8 +16,7 @@ license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'bash'
- 'electron22'
+ "electron${_electronversion}"
)
makedepends=(
'gendesk'
@@ -25,11 +26,15 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${url}/releases/download
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.zip::${url}/releases/download/v${pkgver}/Poddycast-linux-armv7l.zip")
source_i686=("${pkgname%-bin}-${pkgver}-i686.zip::${url}/releases/download/v${pkgver}/Poddycast-linux-ia32.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/Poddycast-linux-x64.zip")
-sha256sums=('a00d29a2264aa2fa31e3ddecc52643a3924fcda917e25953c1ba73fbd55a952c')
+sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
sha256sums_aarch64=('35f4d7a1a43c950a4eb4a242eda4f9442539467364d62aac3c74d837db4983ef')
sha256sums_armv7h=('a29309aa3b2e9c6507404c0d9298350fbe93ca88a6ca13b117782aeb0db3a167')
sha256sums_x86_64=('1b5e2ff12ff8af90a021e70ed8e1f8c2439a16488476252e3b078b9cac4da8a9')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --categories "AudioVideo" --name "${_pkgname}" --exec "${pkgname%-bin}"
}
package() {
diff --git a/poddycast.sh b/poddycast.sh
index 6ceea4598fd0..2ec4412e5c4f 100644
--- a/poddycast.sh
+++ b/poddycast.sh
@@ -1,11 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron22
-APPDIR="/usr/lib/poddycast"
-export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file