summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2022-08-20 13:50:13 +0000
committerSam2022-08-20 13:50:13 +0000
commit3409aa911a49578091559399e13f500149605be2 (patch)
tree5590e58450473d84a88a2289d6897ac5d8d82a07
parentabb4c3db9a64d7496fe771bb6e54a64e946555ee (diff)
downloadaur-3409aa911a49578091559399e13f500149605be2.tar.gz
updpkg: podman-git podman-docker-git 4.2.0_dev.r16114.g31bb53f5f-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--podman-4.2.0-defaultinitpath.patch13
4 files changed, 39 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca1663ff7f6c..a2a464edfeec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = podman-git
pkgdesc = Tool and library for running OCI-based containers in pods (git)
- pkgver = 4.2.0_dev.r15273.ga550af260
+ pkgver = 4.2.0_dev.r16114.g31bb53f5f
pkgrel = 1
url = https://github.com/containers/podman.git
arch = x86_64
@@ -10,19 +10,23 @@ pkgbase = podman-git
makedepends = go-md2man
makedepends = git
makedepends = gcc
+ makedepends = glibc
makedepends = btrfs-progs
- makedepends = catatonit
+ makedepends = catatonit>=0.1.7-2
makedepends = libapparmor.so
makedepends = libdevmapper.so
makedepends = libgpgme.so
makedepends = libseccomp.so
- makedepends = libsystemd
+ makedepends = libsystemd.so
+ makedepends = systemd
options = !lto
source = git+https://github.com/containers/podman.git
+ source = podman-4.2.0-defaultinitpath.patch
sha256sums = SKIP
+ sha256sums = 0f835642a5299d17be36ade891bb7bbbbb4dceef2a715e99fe0580d3a74fec82
pkgname = podman-git
- depends = catatonit
+ depends = catatonit>=0.1.7-2
depends = conmon
depends = containers-common
depends = crun
@@ -30,7 +34,8 @@ pkgname = podman-git
depends = libdevmapper.so
depends = libgpgme.so
depends = libseccomp.so
- depends = libsystemd
+ depends = libsystemd.so
+ depends = systemd
depends = slirp4netns
depends = netavark
depends = aardvark-dns
diff --git a/.gitignore b/.gitignore
index 209eaaefe67f..713b23f44496 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!PKGBUILD
!.SRCINFO
!.gitignore
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 73ca702ba7a5..315f99967af2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,21 @@ pkgbase=podman-git
pkgname=(podman-git podman-docker-git)
_pkgname=podman
_pkgname_docker=podman-docker
-pkgver=4.2.0_dev.r15273.ga550af260
+pkgver=4.2.0_dev.r16114.g31bb53f5f
pkgrel=1
pkgdesc="Tool and library for running OCI-based containers in pods (git)"
arch=(x86_64 aarch64)
-makedepends=(go go-md2man git gcc btrfs-progs catatonit libapparmor.so libdevmapper.so libgpgme.so libseccomp.so libsystemd)
+makedepends=(go go-md2man git gcc glibc btrfs-progs "catatonit>=0.1.7-2" libapparmor.so libdevmapper.so libgpgme.so libseccomp.so libsystemd.so systemd)
# https://github.com/containers/podman/issues/13297
options=(!lto)
url="https://github.com/containers/$_pkgname.git"
license=(Apache)
-source=("git+$url")
-sha256sums=('SKIP')
+source=(
+ "git+$url"
+ "$_pkgname-4.2.0-defaultinitpath.patch"
+)
+sha256sums=('SKIP'
+ '0f835642a5299d17be36ade891bb7bbbbb4dceef2a715e99fe0580d3a74fec82')
pkgver() {
cd "$srcdir/$_pkgname" || exit 1
@@ -25,6 +29,12 @@ pkgver() {
echo "${ver//-/_}.${commit}"
}
+prepare() {
+ # set default init_path to /usr/lib/podman/catatonit
+ # https://bugs.archlinux.org/task/75493
+ patch -Np1 -d $_pkgname -i ../$_pkgname-4.2.0-defaultinitpath.patch
+}
+
build() {
# Fails if using clang
export CC=gcc
@@ -40,7 +50,7 @@ build() {
}
package_podman-git() {
- depends+=(catatonit conmon containers-common crun iptables libdevmapper.so libgpgme.so libseccomp.so libsystemd slirp4netns netavark aardvark-dns)
+ depends+=("catatonit>=0.1.7-2" conmon containers-common crun iptables libdevmapper.so libgpgme.so libseccomp.so libsystemd.so systemd slirp4netns netavark aardvark-dns)
optdepends+=(
'libapparmor.so: support for apparmor'
'libselinux: support for selinux'
diff --git a/podman-4.2.0-defaultinitpath.patch b/podman-4.2.0-defaultinitpath.patch
new file mode 100644
index 000000000000..1a1ded866bc0
--- /dev/null
+++ b/podman-4.2.0-defaultinitpath.patch
@@ -0,0 +1,13 @@
+diff --git i/vendor/github.com/containers/common/pkg/config/default.go w/vendor/github.com/containers/common/pkg/config/default.go
+index c7ddf90ee..639e8f6f9 100644
+--- i/vendor/github.com/containers/common/pkg/config/default.go
++++ w/vendor/github.com/containers/common/pkg/config/default.go
+@@ -50,7 +50,7 @@ const (
+
+ var (
+ // DefaultInitPath is the default path to the container-init binary.
+- DefaultInitPath = "/usr/libexec/podman/catatonit"
++ DefaultInitPath = "/usr/lib/podman/catatonit"
+ // DefaultInfraImage is the default image to run as infrastructure containers in pods.
+ DefaultInfraImage = ""
+ // DefaultRootlessSHMLockPath is the default path for rootless SHM locks. \ No newline at end of file