summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Scarpetta2018-02-26 17:54:39 +0100
committerMarco Scarpetta2018-02-26 17:54:39 +0100
commit6c588d5ef6a832b5c6fc5219e95cc56f098f640a (patch)
tree08181b6e49f3fd0135ea0e1b27240d08c4c075fd
downloadaur-6c588d5ef6a832b5c6fc5219e95cc56f098f640a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84395f2ce961
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = podofo-git
+ pkgdesc = A C++ library to work with the PDF file format
+ pkgver = r1599.5b2f441
+ pkgrel = 1
+ url = http://podofo.sourceforge.net
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = lua
+ depends = openssl
+ depends = fontconfig
+ depends = libtiff
+ depends = libidn
+ depends = libjpeg-turbo
+ provides = podofo
+ conflicts = podofo
+ source = git://github.com/svn2github/podofo.git
+ sha256sums = SKIP
+
+pkgname = podofo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aadeda20b7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Marco Scarpetta <marcoscarpetta02@gmail.com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+# Contributor: Preecha Patumchareonpol <yumyai at gmail.com>
+
+pkgname=podofo-git
+pkgver=r1599.5b2f441
+pkgrel=1
+pkgdesc="A C++ library to work with the PDF file format"
+arch=('x86_64')
+url="http://podofo.sourceforge.net"
+license=('GPL')
+depends=('lua' 'openssl' 'fontconfig' 'libtiff' 'libidn' 'libjpeg-turbo')
+makedepends=('cmake')
+conflicts=('podofo')
+provides=('podofo')
+source=("git://github.com/svn2github/podofo.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/podofo"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}"
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/build"
+ cmake "${srcdir}/podofo" -DCMAKE_INSTALL_PREFIX=/usr \
+ -DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
+ -DPODOFO_BUILD_SHARED=1 \
+ -DPODOFO_HAVE_JPEG_LIB=1 \
+ -DPODOFO_HAVE_PNG_LIB=1 \
+ -DPODOFO_HAVE_TIFF_LIB=1
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR=$pkgdir install
+}