summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorСтрахиња Радић2024-03-13 16:50:02 +0100
committerСтрахиња Радић2024-03-13 16:50:02 +0100
commitffd50e764fbcaaf89dca4957c3795e97ef84ee63 (patch)
treea2cbd7aed0b84d9fc0ea3bb790e01cbb528d7325
parentb824c9ac368ef3a6fac48df88301b5433865b446 (diff)
downloadaur-poe.tar.gz
Fix build systems with preset environment (Artix)
Signed-off-by: Страхиња Радић <contact@strahinja.org>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de09597320d6..237920fcb65e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = poe
pkgdesc = .po file editor
pkgver = 1.7.7
- pkgrel = 1
+ pkgrel = 2
url = https://strahinja.srht.site/poe
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 0dde260f875f..2da37318791a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Strahinya Radich <contact@strahinja.org>
pkgname=poe
pkgver=1.7.7
-pkgrel=1
+pkgrel=2
pkgdesc=".po file editor"
arch=('x86_64')
url="https://strahinja.srht.site/poe"
@@ -11,10 +11,21 @@ md5sums=('ae4e8e98c8eaf8c5576b0eff5fdc2fee')
build() {
cd $pkgname-v$pkgver
+
+ # Some build environments insist on having those preset, which breaks
+ # the build; if you really want some of them, comment the 'unset' lines
+ # below, but note you are on your own wrt errors.
+ unset BINDIR CC CFLAGS CPPFLAGS DOCDIR HEADERS INSTALL LDFLAGS LIBS
+ unset MANPAGE MANPREFIX OBJS PROG SRC
+
FALLBACKVER=$pkgver-$pkgrel PREFIX="$pkgdir/usr" make -e all
}
package() {
cd $pkgname-v$pkgver
+
+ unset BINDIR CC CFLAGS CPPFLAGS DOCDIR HEADERS INSTALL LDFLAGS LIBS
+ unset MANPAGE MANPREFIX OBJS PROG SRC
+
FALLBACKVER=$pkgver-$pkgrel PREFIX="$pkgdir/usr" make -e install
}