summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2017-10-24 12:08:09 +0100
committerEmmanuel Gil Peyrot2017-10-24 12:08:25 +0100
commitd7567eca96439319b9685c7376db5a5fdfc45cd5 (patch)
tree0e1a317b6c378856a74cc4b8032799cfbb2240a7
parentcf8493fa0c3a0f7f02f7d172065c0e82a135bee5 (diff)
downloadaur-d7567eca96439319b9685c7376db5a5fdfc45cd5.tar.gz
Use setup.py build instead of build_ext, add --skip-build to package to avoid doing things twice, remove $srcdir, remove explicit depends versions, add aarch64 as a supported architecture, fix capitalisation of acronyms, and add myself as a maintainer.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35e7b7758b62..906002504560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Oct 8 16:06:01 UTC 2017
+# Tue Oct 24 11:08:18 UTC 2017
pkgbase = poezio
- pkgdesc = A full-featured command-line irc-like xmpp (jabber) client
+ pkgdesc = A full-featured command-line IRC-like XMPP (Jabber) client
pkgver = 0.11
- pkgrel = 2
+ pkgrel = 3
url = https://poez.io
arch = i686
arch = x86_64
arch = armv7h
+ arch = aarch64
license = zlib
makedepends = python-setuptools
- depends = python>=3.4
- depends = python-slixmpp>=1.2.4
+ depends = python
+ depends = python-slixmpp
optdepends = python-pyinotify: Autoaway with screen plugin
optdepends = gnupg: GPG plugin
optdepends = figlet: ASCII art plugin
diff --git a/PKGBUILD b/PKGBUILD
index b709a76a8f11..286bd0db583d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: mathieui <mathieui[at]mathieui.net>
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
pkgname=poezio
-pkgrel=2
pkgver=0.11
-pkgdesc="A full-featured command-line irc-like xmpp (jabber) client"
-arch=('i686' 'x86_64' 'armv7h')
+pkgrel=3
+pkgdesc="A full-featured command-line IRC-like XMPP (Jabber) client"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://poez.io"
license=('zlib')
-depends=('python>=3.4' 'python-slixmpp>=1.2.4')
+depends=('python' 'python-slixmpp')
makedepends=('python-setuptools')
source=("https://dev.louiz.org/attachments/download/118/${pkgname}-${pkgver}.tar.gz")
optdepends=('python-pyinotify: Autoaway with screen plugin'
@@ -19,11 +20,11 @@ optdepends=('python-pyinotify: Autoaway with screen plugin'
sha512sums=('1df750f889c898ea3f463cf9de405d47b53f8d6ef9c75cdc6a8d5279ea4115033a431ff20525601603e1eea0e59355971b400fb5de2bc20df491003928a7064d')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python3 setup.py build_ext --inplace
+ cd $pkgname-$pkgver
+ python3 setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python3 setup.py install --root="$pkgdir/" --optimize=1
+ cd $pkgname-$pkgver
+ python3 setup.py install --skip-build --root="$pkgdir/" --optimize=1
}