summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-02-17 10:22:40 +0100
committerMichael Straube2017-02-17 10:22:40 +0100
commit554f77aa964eba6835f861dc7220d0a0a6710a1f (patch)
treebfa33e1b62e3d5c16237cde055d7f877fa131349
parent558634aa72516a7937732939c33aaaa0ca5077eb (diff)
downloadaur-554f77aa964eba6835f861dc7220d0a0a6710a1f.tar.gz
Update to 0.9
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD25
2 files changed, 23 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ab1698d4c91..0adf7ef7a072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
pkgbase = pogo
pkgdesc = Plays your music. Nothing else.
- pkgver = 0.8.7
- pkgrel = 4
+ pkgver = 0.9
+ pkgrel = 1
url = https://github.com/jendrikseipp/pogo
arch = any
license = GPL
depends = pygtk
- depends = gstreamer0.10-python
- depends = gstreamer0.10-base-plugins
- depends = mutagen
- depends = python2-dbus
- depends = python2-pillow
- depends = gtk2
- optdepends = python2-notify: desktop notifications
+ depends = gst-python
+ depends = python-mutagen
+ depends = python-dbus
+ depends = python-pillow
+ depends = gtk3
+ optdepends = libnotify: desktop notifications
optdepends = gnome-settings-daemon: GNOME media keys
optdepends = pulseaudio: PulseAudio support
- optdepends = gstreamer0.10-good-plugins: PulseAudio support and good codecs
- optdepends = gstreamer0.10-bad-plugins: additional codecs
- optdepends = gstreamer0.10-ugly-plugins: additional codecs
- optdepends = gstreamer0.10-ffmpeg: ffmpeg codec
- source = pogo-0.8.7.tar.gz::https://github.com/jendrikseipp/pogo/archive/v0.8.7.tar.gz
- sha256sums = 144beebc043a834f17580ead90d30b64274d75dda524974d40754ee8344fc6f9
+ optdepends = gst-plugins-good: PulseAudio support and good codecs
+ optdepends = gst-plugins-bad: additional codecs
+ optdepends = gst-plugins-ugly: additional codecs
+ optdepends = gst-libav: libav codec
+ source = pogo-0.9.tar.gz::https://github.com/jendrikseipp/pogo/archive/v0.9.tar.gz
+ sha256sums = 1a0ea47d4bd6ee674dee7825d7adbe91c4d62c0c260c49ba33fd10c12b9c3fb4
pkgname = pogo
diff --git a/PKGBUILD b/PKGBUILD
index 2579dca4f718..0d9ff790a463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,22 @@
# Maintainer: Michael Straube <straubem@gmx.de>
pkgname=pogo
-pkgver=0.8.7
-pkgrel=4
+pkgver=0.9
+pkgrel=1
pkgdesc='Plays your music. Nothing else.'
arch=('any')
url='https://github.com/jendrikseipp/pogo'
license=('GPL')
-depends=('pygtk' 'gstreamer0.10-python' 'gstreamer0.10-base-plugins' 'mutagen'
- 'python2-dbus' 'python2-pillow' 'gtk2')
-optdepends=('python2-notify: desktop notifications'
+depends=('pygtk' 'gst-python' 'python-mutagen' 'python-dbus' 'python-pillow' 'gtk3')
+optdepends=('libnotify: desktop notifications'
'gnome-settings-daemon: GNOME media keys'
'pulseaudio: PulseAudio support'
- 'gstreamer0.10-good-plugins: PulseAudio support and good codecs'
- 'gstreamer0.10-bad-plugins: additional codecs'
- 'gstreamer0.10-ugly-plugins: additional codecs'
- 'gstreamer0.10-ffmpeg: ffmpeg codec')
+ 'gst-plugins-good: PulseAudio support and good codecs'
+ 'gst-plugins-bad: additional codecs'
+ 'gst-plugins-ugly: additional codecs'
+ 'gst-libav: libav codec')
source=("$pkgname-$pkgver.tar.gz::https://github.com/jendrikseipp/pogo/archive/v$pkgver.tar.gz")
-sha256sums=('144beebc043a834f17580ead90d30b64274d75dda524974d40754ee8344fc6f9')
-
-prepare() {
- cd $pkgname-$pkgver
-
- sed -i 's/python/python2/' pogo.py
-}
+sha256sums=('1a0ea47d4bd6ee674dee7825d7adbe91c4d62c0c260c49ba33fd10c12b9c3fb4')
package() {
cd $pkgname-$pkgver