summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianfeng Zhang2016-08-18 14:40:12 +0800
committerJianfeng Zhang2016-08-18 14:40:12 +0800
commita8b49227f742c803336ac4e670150dd41b5f3d78 (patch)
tree511654559f45273ac608aaa13608accdc08bef77
downloadaur-a8b49227f742c803336ac4e670150dd41b5f3d78.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD51
-rw-r--r--poi.desktop7
-rw-r--r--poi.sh3
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5737cfebcfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = poi
+ pkgdesc = Scalable KanColle browser and tool
+ pkgver = 7.0.0.beta.5.0.g08bb147
+ pkgrel = 1
+ url = https://github.com/poooi/poi/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = coreutils
+ makedepends = findutils
+ makedepends = sed
+ makedepends = imagemagick
+ depends = electron
+ depends = sh
+ provides = poi
+ conflicts = poi
+ source = git+https://github.com/poooi/poi.git#tag=v7.0.0-beta.5
+ source = poi.desktop
+ source = poi.sh
+ sha1sums = SKIP
+ sha1sums = 0578634a64fbb2de2fd35555471a761231a3dc94
+ sha1sums = 321cecdb8f68fb087dfcaa1233ae5ce784095029
+
+pkgname = poi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..affc8448f6c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+pkgname=poi
+_pkgname=poi
+pkgver=7.0.0.beta.5.0.g08bb147
+_pkgver='7.0.0-beta.5'
+pkgrel=1
+pkgdesc="Scalable KanColle browser and tool"
+arch=('any')
+url="https://github.com/poooi/poi/"
+license=('MIT')
+depends=('electron' 'sh')
+makedepends=('git' 'npm' 'coreutils' 'findutils' 'sed' 'imagemagick')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/poooi/poi.git#tag=v${_pkgver}"
+ "${_pkgname}.desktop"
+ "${_pkgname}.sh")
+sha1sums=('SKIP'
+ '0578634a64fbb2de2fd35555471a761231a3dc94'
+ '321cecdb8f68fb087dfcaa1233ae5ce784095029')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags --long | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ sed -i 's/^.*"electron-prebuilt".*$//;s/^.*"electron-builder".*$//' package.json
+ npm install
+ npm run deploy
+}
+
+package() {
+ cd "${srcdir}"
+
+ find "${_pkgname}" -not -path '*/\.*' -type f -exec install -Dm644 {} "${pkgdir}/usr/share/{}" \;
+
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ for s in 16 24 32 48 64 96 128 512; do
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/${s}x${s}/apps"
+ convert "${_pkgname}/assets/icons/poi.png" -resize ${s}x${s} "${pkgdir}/usr/share/icons/hicolor/${s}x${s}/apps/${_pkgname}.png"
+ done
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${_pkgname}"
+ ln -s "../../${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ chmod 0755 "${pkgdir}/usr/bin/${_pkgname}"
+}
diff --git a/poi.desktop b/poi.desktop
new file mode 100644
index 000000000000..e5ca16ae3257
--- /dev/null
+++ b/poi.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=poi
+Comment=poi the KanColle Browser Tool
+Exec="/usr/bin/poi"
+Terminal=false
+Type=Application
+Icon=poi
diff --git a/poi.sh b/poi.sh
new file mode 100644
index 000000000000..8376761a3163
--- /dev/null
+++ b/poi.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/env sh
+
+/usr/bin/electron /usr/share/poi