summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2016-10-02 14:50:10 +0200
committerbartus2016-10-02 14:50:10 +0200
commit5d71c223d070c0e9ded4c911753ec1df66bc345a (patch)
tree835c30e1b7533bafb27c9161c9515dcb6238f070
downloadaur-5d71c223d070c0e9ded4c911753ec1df66bc345a.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09ebf8543c92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = poissonrecon-git
+ pkgdesc = Screened Poisson Surface Reconstruction (and Smoothed Signed Distance Reconstruction)
+ pkgver = 8.0.r10.ge12fe56
+ pkgrel = 1
+ url = http://www.cs.jhu.edu/~misha/Code/PoissonRecon/Version9.0/
+ arch = i686
+ arch = x86_64
+ groups = photogrametry
+ license = MIT
+ makedepends = git
+ depends = glibc
+ depends = gcc-libs
+ provides = poissonrecon
+ provides = ssdrecon
+ provides = surfacetrimmer
+ source = poissonrecon-git::git+https://github.com/mkazhdan/PoissonRecon.git
+ md5sums = SKIP
+
+pkgname = poissonrecon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f36418eacf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: bartus <aur@bartus.33mail.com>
+pkgname=poissonrecon-git
+pkgver=8.0.r10.ge12fe56
+pkgrel=1
+pkgdesc="Screened Poisson Surface Reconstruction (and Smoothed Signed Distance Reconstruction)"
+arch=('i686' 'x86_64')
+url="http://www.cs.jhu.edu/~misha/Code/PoissonRecon/Version9.0/"
+license=('MIT')
+groups=('photogrametry')
+depends=('glibc' 'gcc-libs')
+makedepends=('git')
+provides=('poissonrecon' 'ssdrecon' 'surfacetrimmer')
+source=("${pkgname}::git+https://github.com/mkazhdan/PoissonRecon.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ # cutting off 'V' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^V//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+ install -Dm755 Bin/Linux/PoissonRecon ${pkgdir}/usr/bin/poisson-recon
+ install -Dm755 Bin/Linux/SSDRecon ${pkgdir}/usr/bin/ssd-recon
+ install -Dm755 Bin/Linux/SurfaceTrimmer ${pkgdir}/usr/bin/surface-trimmer
+}
+
+# vim:set ts=2 sw=2 et: