summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdithyan-KV2021-08-11 01:52:03 +0530
committerAdithyan-KV2021-08-11 01:52:03 +0530
commit012a49b42baa303549c5c5e8759086abaef6a42e (patch)
tree2cdf4d2c5b8b611e52e8971a8da71f6abc51eaaa
parentb760e5877538d78468373962999c04ba5395f8e8 (diff)
downloadaur-012a49b42baa303549c5c5e8759086abaef6a42e.tar.gz
Bug fix: PKGBUILD was only a symlink. Now actually added the file
-rw-r--r--[l---------]PKGBUILD34
1 files changed, 33 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 010196ab3eef..a3096f9dac7f 120000..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1 +1,33 @@
-/home/adithyankv/Code/pokemon-colorscripts/PKGBUILD \ No newline at end of file
+# Maintainer: Phoney Badger <badgerphoney at gmail dot com>
+pkgname=pokemon-colorscripts-git
+_pkgname=pokemon-colorscripts
+pkgver=r54.356ccaa
+pkgrel=1
+pkgdesc="CLI utility that prints unicode sprites of pokemon to the terminal"
+arch=('any')
+url="https://gitlab.com/phoneybadger/pokemon-colorscripts.git"
+license=('MIT')
+depends=('coreutils')
+makedepends=('git')
+source=("$_pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver(){
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ # Creating necessary directories and copying files
+ rm -rf "$pkgdir/usr/local/opt/$_pkgname"
+ mkdir -p "$pkgdir/usr/local/opt/$_pkgname/colorscripts"
+ mkdir -p "$pkgdir/usr/local/bin"
+ install -Dm644 colorscripts/* -t "$pkgdir/usr/local/opt/$_pkgname/colorscripts"
+ install -Dm644 nameslist.txt "$pkgdir/usr/local/opt/$_pkgname/nameslist.txt"
+ install -Dm755 pokemon-colorscripts.sh "$pkgdir/usr/local/opt/$_pkgname/pokemon-colorscripts.sh"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+ # creating symlink in usr/local/bin
+ ln -sf "/usr/local/opt/$_pkgname/pokemon-colorscripts.sh" "$pkgdir/usr/local/bin/pokemon-colorscripts"
+}