summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-08-09 09:34:48 +0100
committerGrey Christoforo2016-08-09 09:34:48 +0100
commit25cc34a31ab83b52034d0a085d508ed864e38971 (patch)
treedf295819872f60ad74f86748b95190f10c94b1d6
parent3a7b14ac573851f46453c873efadc75f5f1b72a6 (diff)
parentb9349910b70ce8bceebaeba3132eb0abea17320d (diff)
downloadaur-25cc34a31ab83b52034d0a085d508ed864e38971.tar.gz
Merge branch 'master' of ssh+git://aur.archlinux.org/pokemon-go-map
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca1c7ddf35b4..996eb2a5d93f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Aug 9 08:29:58 UTC 2016
+# Tue Aug 9 08:34:45 UTC 2016
pkgbase = pokemon-go-map
pkgdesc = Live visualization of all the pokemon in your area... and more! (stable releases)
pkgver = 2.2.0
@@ -7,7 +7,11 @@ pkgbase = pokemon-go-map
url = https://pokemongomap.github.io/PoGoMapWebsite/
arch = any
license = GNU GPLv3+
+ depends = nodejs-grunt-cli
depends = python2
+ depends = npm
+ depends = python2-configargparse
+ depends = python2-flask-compress
depends = python2-protobuf-to-dict
depends = python2-peewee
depends = python2-s2sphere
diff --git a/PKGBUILD b/PKGBUILD
index 48ff94cc8380..b61e9adcb91e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,20 @@ pkgdesc='Live visualization of all the pokemon in your area... and more! (stable
arch=('any')
url='https://pokemongomap.github.io/PoGoMapWebsite/'
license=('GNU GPLv3+')
-depends=( 'python2' 'python2-protobuf-to-dict' 'python2-peewee' 'python2-s2sphere' 'python2-flask-cors' 'python2-flask' 'python2-geopy' 'python2-protobuf' 'python2-requests' 'python2-gpsoauth' 'python2-werkzeug')
+depends=( 'nodejs-grunt-cli' 'python2' 'npm' 'python2-configargparse' 'python2-flask-compress' 'python2-protobuf-to-dict' 'python2-peewee' 'python2-s2sphere' 'python2-flask-cors' 'python2-flask' 'python2-geopy' 'python2-protobuf' 'python2-requests' 'python2-gpsoauth' 'python2-werkzeug')
source=("https://github.com/PokemonGoMap/PokemonGo-Map/archive/V${pkgver}.tar.gz")
md5sums=('3f45144ec3bc7b2245f0923387759d4d')
+build() {
+ cd "${srcdir}/PokemonGo-Map-${pkgver}"
+ npm install
+ grunt build
+ npm run-script build
+}
+
package() {
+ cd "${srcdir}/PokemonGo-Map-${pkgver}"
mkdir -p "${pkgdir}/opt/"
cp -a "${srcdir}/PokemonGo-Map-${pkgver}" "${pkgdir}/opt/${pkgname}"
+ rm -rf "${pkgdir}/opt/${pkgname}/node_modules"
}