summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-07-30 13:01:14 +0100
committerGrey Christoforo2016-07-30 13:01:14 +0100
commitf45cee3f5b28dce348dda8efa535ccc6f7d55fdc (patch)
tree242a749355c71f68a558b1c1febae26d47bcc04d
parent4c61ea19f4cdfb8731c19892cbb24b940e611ed4 (diff)
downloadaur-f45cee3f5b28dce348dda8efa535ccc6f7d55fdc.tar.gz
build update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1aee102afe6d..c26ca9d1857c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Jul 29 19:38:49 UTC 2016
+# Sat Jul 30 12:01:09 UTC 2016
pkgbase = pokemon-go-map
pkgdesc = Live visualization of all the pokemon in your area... and more! (stable releases)
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://jz6.github.io/PoGoMap/
arch = any
license = GNU GPLv3+
+ depends = nodejs-grunt-cli
depends = python2
+ depends = npm
depends = python2-configargparse
depends = python2-flask-compress
depends = python2-protobuf-to-dict
diff --git a/PKGBUILD b/PKGBUILD
index 42f5c205ca09..707ae132a3bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,24 @@
pkgname=pokemon-go-map
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Live visualization of all the pokemon in your area... and more! (stable releases)'
arch=('any')
url='https://jz6.github.io/PoGoMap/'
license=('GNU GPLv3+')
-depends=( 'python2' 'python2-configargparse' 'python2-flask-compress' 'python2-protobuf-to-dict' 'python2-peewee' 'python2-s2sphere' 'python2-flask-cors' 'python2-flask' 'python2-geopy' 'python2-protobuf' 'python2-requests' 'python2-gpsoauth' 'python2-werkzeug')
+depends=( 'nodejs-grunt-cli' 'python2' 'npm' 'python2-configargparse' 'python2-flask-compress' 'python2-protobuf-to-dict' 'python2-peewee' 'python2-s2sphere' 'python2-flask-cors' 'python2-flask' 'python2-geopy' 'python2-protobuf' 'python2-requests' 'python2-gpsoauth' 'python2-werkzeug')
source=("https://github.com/AHAAAAAAA/PokemonGo-Map/archive/v${pkgver}.tar.gz")
md5sums=('fbba2ca161fadf68186f0fde5f671833')
+build() {
+ cd "${srcdir}/PokemonGo-Map-${pkgver}"
+ #npm install
+ #npm run-script build
+}
+
package() {
cd "${srcdir}/PokemonGo-Map-${pkgver}"
mkdir -p "${pkgdir}/opt/"
cp -a "${srcdir}/PokemonGo-Map-${pkgver}" "${pkgdir}/opt/${pkgname}"
+ rm -rf "${pkgdir}/opt/${pkgname}/node_modules"
}