summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTids2016-06-14 13:46:41 +0200
committerTids2016-06-14 13:46:41 +0200
commitc4134abe8e32b33d840a7f137cf6e677901c0043 (patch)
treefdbaf6be42c505780c48fafabb498b8d0fd5bfb9
parent3d27d8b3839bcdc1db8b3716a37dffbbb1521bb7 (diff)
downloadaur-c4134abe8e32b33d840a7f137cf6e677901c0043.tar.gz
install script added
-rw-r--r--.SRCINFO10
-rw-r--r--INSTALL25
-rw-r--r--PKGBUILD21
-rw-r--r--change.log7
4 files changed, 47 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b038cd897cd..0a7d6f4ab92e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = pokemon-revolution-online-bin
pkgdesc = A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games.
- pkgver = 0.94.20160509
- pkgrel = 1
+ pkgver = 0.95.2.20160614
+ pkgrel = 3
url = http://pokemon-revolution-online.net
+ install = INSTALL
changelog = change.log
arch = x86_64
license = custom
+ makedepends = unzip
depends = gcc-libs-multilib
+ depends = xdg-utils
+ depends = desktop-file-utils
optdepends = gtk2: required for the Unity ScreenSelector plugin
conflicts = pokemon-revolution-online
source = net.pokemon-revolution-online.desktop
@@ -15,7 +19,7 @@ pkgbase = pokemon-revolution-online-bin
source = copyright
source = pokemonrevolution.svg
md5sums = 3215173b6f1673d868e71f1d953ed9d2
- md5sums = 1a6d6b3aeee7c84cd38cafb715ffec8a
+ md5sums = 03fa9c99e0c2730f6b618d4283a2c5dc
md5sums = 1b667f450341675b6b2c1750e034516c
md5sums = 0efcd0393015ff149217f9ced4670513
md5sums = 8446ead3097e1b87e3a63b667d956569
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 000000000000..16da32e36872
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,25 @@
+post_install() {
+ xdg-icon-resource forceupdate
+ update-desktop-database -q
+ echo
+ echo
+ echo -e "\t GAME NOTES"
+ echo -e "\t ´*~##############~*\`"
+ echo -e "\t##########################################################"
+ echo -e "\t# #"
+ echo -e "\t# You need to create an account at #"
+ echo -e "\t# http://www.pokemon-revolution-online.net/Register.php #"
+ echo -e "\t# #"
+ echo -e "\t##########################################################"
+ echo
+ echo
+
+}
+
+post_upgrade() {
+ xdg-icon-resource forceupdate
+ update-desktop-database -q
+}
+
+
+
diff --git a/PKGBUILD b/PKGBUILD
index 0909a97ba5d5..e5a699e3b3e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Fabian <plusfabi[AT+thegoogleadress]>
pkgname=pokemon-revolution-online-bin
-pkgver=0.95.20160613
-pkgrel=1
+pkgver=0.95.2.20160614
+pkgrel=3
pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
arch=('x86_64')
url="http://pokemon-revolution-online.net"
license=('custom')
-depends=('gcc-libs-multilib' 'xdg-utils' 'desktop-file-utils' 'unzip')
+depends=('gcc-libs-multilib' 'xdg-utils' 'desktop-file-utils')
+makedepends=('unzip')
optdepends=('gtk2: required for the Unity ScreenSelector plugin')
conflicts=('pokemon-revolution-online')
changelog="change.log"
+install="INSTALL"
source=('net.pokemon-revolution-online.desktop' 'change.log' 'pokemonrevolution' 'copyright' 'pokemonrevolution.svg')
md5sums=('3215173b6f1673d868e71f1d953ed9d2'
- '4ada7224dfa493e7a50fe93b4605c944'
+ '03fa9c99e0c2730f6b618d4283a2c5dc'
'1b667f450341675b6b2c1750e034516c'
'0efcd0393015ff149217f9ced4670513'
'8446ead3097e1b87e3a63b667d956569')
@@ -23,12 +25,12 @@ package() {
# Variables
## i know this isnt a good thing and nobody wants to see this on aur, but itll make things easier for me #Fabian
## directory files naming is usually VNAMING_Date, binary VNAMING.x86_64
- __VNAMING="PROLinux64_95"
+ __VNAMING="PROLinux64_952"
__DLDIR=$(xdg-user-dir DOWNLOAD)
__DDLA="http://tiny.cc/PROLinux"
- __DDLFN="PROLinux.zip"
- __DDLFMD5="5babd90543bb77a80806dcd800c183b0"
+ __DDLFN="PRO952_Linux.zip"
+ __DDLFMD5="bd2be1a626b202b1df26398371de6693"
## "Something's missing"? -> No One Cares - Atreyu c;
if [ ! -f ${__DLDIR}/${__DDLFN} ]; then
@@ -99,8 +101,3 @@ package() {
install -D -m644 "${srcdir}/copyright" \
"${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
}
-
-post_install() {
- xdg-icon-resource forceupdate
- update-desktop-database -q
-}
diff --git a/change.log b/change.log
index db05cfc7f7a0..d78b383613ce 100644
--- a/change.log
+++ b/change.log
@@ -1,7 +1,12 @@
Game Changelog
http://pokemon-revolution-online.net/Forum/viewtopic.php?f=14&t=4563
-0.94.20160613-1
+0.95.2.20160614-3
+* new upstream version
+* move unzip to makedepends
+* now with install
+
+0.95.20160613-1
* new version of PRO
* added 'unzip' 'xdg-utils' 'desktop-file-utils' as dependency
* using unzip as bsdtar also bsdtar: Invalid central directory signature ;; bsdtar: Error exit delayed from previous errors.