summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHelton Reis2021-05-24 19:34:38 -0300
committerHelton Reis2021-05-24 19:34:38 -0300
commitdcda47c7634dd667ac2a37cfa8ccb10af0107ecb (patch)
tree9c193e2e9ac2565379922f6679cf7b30af6cd2de
downloadaur-dcda47c7634dd667ac2a37cfa8ccb10af0107ecb.tar.gz
[misc] Initial commit
-rw-r--r--.SRCINFO14
-rwxr-xr-x.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b38b89f11a33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pokemonsay-newgenerations-git
+ pkgdesc = Brings pokemon to the terminal using the power of cowsay.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/HRKings/pokemonsay-newgenerations.git
+ arch = any
+ license = unknown
+ depends = cowsay
+ provides = pokemonsay
+ source = git+https://github.com/HRKings/pokemonsay-newgenerations.git
+ md5sums = SKIP
+
+pkgname = pokemonsay-newgenerations-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..74440c716c3d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pokemonsay-newgenerations/
+*.pkg.tar.*
+src/
+srcdir/
+pkg/
+pkgdir/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40687f52286c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: HRKings <hrkings@***.com>
+pkgname=pokemonsay-newgenerations-git
+_pkgname=pokemonsay-newgenerations
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Brings pokemon to the terminal using the power of cowsay."
+arch=(any)
+url="https://github.com/HRKings/pokemonsay-newgenerations.git"
+license=('unknown')
+depends=(cowsay)
+provides=(pokemonsay)
+source=("git+${url}")
+md5sums=('SKIP')
+
+package() {
+ cd ${_pkgname}
+ # Copy pokemon cowfiles
+ rm -rf "${pkgdir}/opt/${_pkgname}/pokemons"
+ mkdir -p "${pkgdir}/opt/${_pkgname}/pokemons"
+ cp ./pokemons/* "${pkgdir}/opt/${_pkgname}/pokemons/"
+
+ # Install the README
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # Put the installation path on the script
+ sed -r "31s;.*;INSTALL_PATH=${pkgdir}/opt/${_pkgname}/;" -i pokemonsay.sh
+
+ # Install the scripts
+ install -Dm755 pokemonsay.sh "${pkgdir}"/usr/bin/pokemonsay
+ install -Dm755 pokemonthink.sh "${pkgdir}"/usr/bin/pokemonthink
+} \ No newline at end of file