summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktav2019-10-29 18:34:18 +0100
committerblacktav2019-10-29 18:34:18 +0100
commit1b63e14f72af4dc9ef9fdb145dd87043299ce218 (patch)
tree389dff38090d7ed9ea46b9ee6b8c9a6140fd1e58
parentd5e191252dd492d6a2d23d636ada81936be9caff (diff)
downloadaur-1b63e14f72af4dc9ef9fdb145dd87043299ce218.tar.gz
Added Patch for boost issue
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--pokerth-1.1.2.patch.201987
3 files changed, 92 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be08c2825de9..0bdb36fc50aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pokerth
pkgdesc = Client to online Poker game written in C++/QT
pkgver = 1.1.2
- pkgrel = 9
+ pkgrel = 10
url = http://www.pokerth.net/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5328ddaa8610..a73083c04e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pokerth
pkgver=1.1.2
-pkgrel=9
+pkgrel=10
pkgdesc="Client to online Poker game written in C++/QT"
arch=('i686' 'x86_64')
url="http://www.pokerth.net/"
@@ -25,6 +25,9 @@ prepare() {
# these changes should be incorporated in next release ~feb-2018
patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch"
# ----------------------------------------------------------------------------
+ # changes to permit building with boost 1.70
+ patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2019"
+ # ----------------------------------------------------------------------------
# good idea to do this at all times
protoc -I=$srcdir/$pkgname-$pkgver-rc/ --cpp_out=$srcdir/$pkgname-$pkgver-rc/src/third_party/protobuf/ $srcdir/$pkgname-$pkgver-rc/pokerth.proto $srcdir/$pkgname-$pkgver-rc/chatcleaner.proto
diff --git a/pokerth-1.1.2.patch.2019 b/pokerth-1.1.2.patch.2019
new file mode 100644
index 000000000000..50aced79f1c2
--- /dev/null
+++ b/pokerth-1.1.2.patch.2019
@@ -0,0 +1,87 @@
+diff --git pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/connection.hpp pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/connection.hpp
+--- pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/connection.hpp
++++ pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/connection.hpp
+@@ -311,9 +311,10 @@ public:
+ * needed.
+ */
+ timer_ptr set_timer(long duration, timer_handler callback) {
+- timer_ptr new_timer = lib::make_shared<lib::asio::steady_timer>(
+- lib::ref(*m_io_service),
+- lib::asio::milliseconds(duration)
++ timer_ptr new_timer(
++ new lib::asio::steady_timer(
++ *m_io_service,
++ lib::asio::milliseconds(duration))
+ );
+
+ if (config::enable_multithreading) {
+@@ -461,8 +462,7 @@ protected:
+ m_io_service = io_service;
+
+ if (config::enable_multithreading) {
+- m_strand = lib::make_shared<lib::asio::io_service::strand>(
+- lib::ref(*io_service));
++ m_strand.reset(new lib::asio::io_service::strand(*io_service));
+ }
+
+ lib::error_code ec = socket_con_type::init_asio(io_service, m_strand,
+diff --git pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/endpoint.hpp pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/endpoint.hpp
+--- pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/endpoint.hpp
++++ pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/endpoint.hpp
+@@ -191,8 +191,7 @@ public:
+
+ m_io_service = ptr;
+ m_external_io_service = true;
+- m_acceptor = lib::make_shared<lib::asio::ip::tcp::acceptor>(
+- lib::ref(*m_io_service));
++ m_acceptor.reset(new lib::asio::ip::tcp::acceptor(*m_io_service));
+
+ m_state = READY;
+ ec = lib::error_code();
+@@ -660,9 +659,7 @@ public:
+ * @since 0.3.0
+ */
+ void start_perpetual() {
+- m_work = lib::make_shared<lib::asio::io_service::work>(
+- lib::ref(*m_io_service)
+- );
++ m_work.reset(new lib::asio::io_service::work(*m_io_service));
+ }
+
+ /// Clears the endpoint's perpetual flag, allowing it to exit when empty
+@@ -826,8 +823,7 @@ protected:
+
+ // Create a resolver
+ if (!m_resolver) {
+- m_resolver = lib::make_shared<lib::asio::ip::tcp::resolver>(
+- lib::ref(*m_io_service));
++ m_resolver.reset(new lib::asio::ip::tcp::resolver(*m_io_service));
+ }
+
+ tcon->set_uri(u);
+diff --git pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/none.hpp pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/websocketpp/transport/asio/security/none.hpp
+--- pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/none.hpp
++++ pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/none.hpp
+@@ -168,8 +168,7 @@ protected:
+ return socket::make_error_code(socket::error::invalid_state);
+ }
+
+- m_socket = lib::make_shared<lib::asio::ip::tcp::socket>(
+- lib::ref(*service));
++ m_socket.reset(new lib::asio::ip::tcp::socket(*service));
+
+ m_state = READY;
+
+diff --git pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/tls.hpp pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/tls.hpp
+--- pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/tls.hpp
++++ pokerth-1.1.2-rc/src/third_party/websocketpp/websocketpp/transport/asio/security/tls.hpp
+@@ -193,8 +193,7 @@ protected:
+ if (!m_context) {
+ return socket::make_error_code(socket::error::invalid_tls_context);
+ }
+- m_socket = lib::make_shared<socket_type>(
+- _WEBSOCKETPP_REF(*service),lib::ref(*m_context));
++ m_socket.reset(new socket_type(*service, *m_context));
+
+ m_io_service = service;
+ m_strand = strand;