summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktav2023-07-04 23:59:00 +0200
committerblacktav2023-07-04 23:59:00 +0200
commit771617fa14ee5416b0bc20a6cce698bc064c3ef9 (patch)
tree530fd5cec100ec684587150b8a09592e003d122c
parente9b25162111b6d4d92819bfb1e0f6e8a38a6de1e (diff)
downloadaur-771617fa14ee5416b0bc20a6cce698bc064c3ef9.tar.gz
added patch to explicitly link inherited libs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--pokerth-1.1.2.patch.202313
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2db53511ec8..aac295aa572d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pokerth
pkgdesc = Client to online Poker game written in C++/QT
pkgver = 1.1.2
- pkgrel = 25
+ pkgrel = 26
url = http://www.pokerth.net/
arch = i686
arch = x86_64
@@ -19,9 +19,11 @@ pkgbase = pokerth
source = pokerth-1.1.2.patch
source = pokerth-1.1.2.patch.2019
source = pokerth-1.1.2.patch.2020
+ source = pokerth-1.1.2.patch.2023
md5sums = 8fd7d7fc7ece17315e58aa3240dd4586
md5sums = 0ef5541fc6008dfb2521dcab47afb659
md5sums = 50d427bd8afc57fb61e186de6c4e5601
md5sums = e5bf2357733b4508737f8271f3c1e65f
+ md5sums = 38e079c6c4943cc4466c5bb402bd8dd6
pkgname = pokerth
diff --git a/PKGBUILD b/PKGBUILD
index 35ed41617f05..48ad245cabff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pokerth
pkgver=1.1.2
-pkgrel=25
+pkgrel=26
pkgdesc="Client to online Poker game written in C++/QT"
arch=('i686' 'x86_64')
url="http://www.pokerth.net/"
@@ -17,11 +17,13 @@ makedepends=('boost')
source=(https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
${pkgname}-${pkgver}.patch
${pkgname}-${pkgver}.patch.2019
- ${pkgname}-${pkgver}.patch.2020)
+ ${pkgname}-${pkgver}.patch.2020
+ ${pkgname}-${pkgver}.patch.2023)
md5sums=('8fd7d7fc7ece17315e58aa3240dd4586'
'0ef5541fc6008dfb2521dcab47afb659'
'50d427bd8afc57fb61e186de6c4e5601'
- 'e5bf2357733b4508737f8271f3c1e65f')
+ 'e5bf2357733b4508737f8271f3c1e65f'
+ '38e079c6c4943cc4466c5bb402bd8dd6')
prepare() {
cd "$srcdir/$pkgname-$pkgver-rc"
@@ -37,6 +39,10 @@ prepare() {
# see also DEFINE+="BOOST_BIND_GLOBAL_PLACEHOLDERS" in build below
patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2020"
# ----------------------------------------------------------------------------
+ # change to explicitly link /usr/lib/libabsl_log_internal_message.so and
+ # /usr/lib/libabsl_log_internal_check_op.so
+ patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2023"
+ # ----------------------------------------------------------------------------
# good idea to do this at all times
protoc -I=$srcdir/$pkgname-$pkgver-rc/ --cpp_out=$srcdir/$pkgname-$pkgver-rc/src/third_party/protobuf/ $srcdir/$pkgname-$pkgver-rc/pokerth.proto $srcdir/$pkgname-$pkgver-rc/chatcleaner.proto
diff --git a/pokerth-1.1.2.patch.2023 b/pokerth-1.1.2.patch.2023
new file mode 100644
index 000000000000..96f29eacb714
--- /dev/null
+++ b/pokerth-1.1.2.patch.2023
@@ -0,0 +1,13 @@
+--- pokerth-1.1.2-rc/pokerth_game.pro 2023-07-04 22:43:50.069300036 +0200
++++ pokerth-1.1.2-rc/pokerth_game.pro 2023-07-04 23:39:38.849095436 +0200
+@@ -524,7 +524,9 @@
+ kFreeBSD = $$find(UNAME, "kFreeBSD")
+ LIBS += -lsqlite3 \
+ -ltinyxml \
+- -lprotobuf
++ -lprotobuf \
++ /usr/lib/libabsl_log_internal_message.so \
++ /usr/lib/libabsl_log_internal_check_op.so
+ LIBS += $$BOOST_LIBS
+ LIBS += -lSDL \
+ -lSDL_mixer \