summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktav2023-11-18 00:38:06 +0100
committerblacktav2023-11-18 00:38:06 +0100
commit89cabe921d35b31ca89ae591356863112e6344c9 (patch)
treed1a1aaef0bfcf2f7ac33a8f7e9830e19990f82b6
parenteec0cd8836575c8f2bcbb4561eb2d0d3fd472a99 (diff)
downloadaur-89cabe921d35b31ca89ae591356863112e6344c9.tar.gz
revert to release 29
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD5
-rw-r--r--PKGBUILD.qt486
-rw-r--r--patch.txt14
-rw-r--r--refresh.sh23
-rw-r--r--srcinfo2
6 files changed, 128 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbd7a0127d12..e69de29bb2d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +0,0 @@
-pkgbase = pokerth
- pkgdesc = Client to online Poker game written in C++/Qt
- pkgver = 1.1.2
- pkgrel = 34
- url = http://www.pokerth.net/
- arch = i686
- arch = x86_64
- license = GPL
- license = custom
- makedepends = boost
- depends = curl
- depends = boost-libs
- depends = gsasl
- depends = protobuf
- depends = qt5-base
- depends = sdl_mixer
- depends = tinyxml
- source = https://sourceforge.net/projects/pokerth/files/pokerth/1.1.2/pokerth-1.1.2.tar.gz
- source = pokerth-1.1.2.patch
- source = pokerth-1.1.2.patch.2019
- source = pokerth-1.1.2.patch.2020
- source = pokerth-1.1.2.patch.2023
- source = pokerth-1.1.2.patch.xdg.2023
- md5sums = 8fd7d7fc7ece17315e58aa3240dd4586
- md5sums = 0ef5541fc6008dfb2521dcab47afb659
- md5sums = 50d427bd8afc57fb61e186de6c4e5601
- md5sums = 2204bc9d820057d5d4b04d675cf09198
- md5sums = 5efeb1305e3d6ff4b60edf1fd7f939b6
- md5sums = e61eae14e6394f4745245e2ef42d812c
-
-pkgname = pokerth
diff --git a/PKGBUILD b/PKGBUILD
index cb8d706c43ab..1cf978520b4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,9 @@
pkgname=pokerth
pkgver=1.1.2
-pkgrel=34
+<<<<<<< HEAD
+pkgrel=35
+
pkgdesc="Client to online Poker game written in C++/Qt"
arch=('i686' 'x86_64')
url="http://www.pokerth.net/"
@@ -47,7 +49,6 @@ prepare() {
patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2023"
# ----------------------------------------------------------------------------
# change to use XDG_CONFIG_HOME if available
- # currently sets folder within XDG_CONFIG_HOME to be .pokerth rather than pokerth
# changes suggested by @viktoracoric
# patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.xdg.2023"
# ----------------------------------------------------------------------------
diff --git a/PKGBUILD.qt4 b/PKGBUILD.qt4
new file mode 100644
index 000000000000..5951e1a05379
--- /dev/null
+++ b/PKGBUILD.qt4
@@ -0,0 +1,86 @@
+# Maintainer: blacktav <blacktav at gmail dot com>
+# Contributor: based on unknown abandoned pokerth-final from 2012-12-27
+
+pkgname=pokerth
+pkgver=1.1.2
+pkgrel=2
+pkgdesc="Client to online Poker game written in C++/Qt"
+arch=('i686' 'x86_64')
+url="http://www.pokerth.net/"
+license=('GPL' 'custom')
+depends=('curl' 'boost-libs' 'gsasl' 'protobuf'
+ 'qt4'
+# 'qt5-3d'
+# 'qt5-base'
+# 'qt5-canvas3d'
+# 'qt5-charts'
+# 'qt5-connectivity'
+# 'qt5-datavis3d'
+# 'qt5-declarative'
+# 'qt5-gamepad'
+# 'qt5-graphicaleffects'
+# 'qt5-imageformats'
+# 'qt5-location'
+# 'qt5-multimedia'
+# 'qt5-networkauth'
+# 'qt5-quickcontrols'
+# 'qt5-quickcontrols2'
+# 'qt5-remoteobjects'
+# 'qt5-script'
+# 'qt5-scxml'
+# 'qt5-sensors'
+# 'qt5-serialbus'
+# 'qt5-serialport'
+# 'qt5-speech'
+# 'qt5-svg'
+# 'qt5-tools'
+# 'qt5-translations'
+# 'qt5-virtualkeyboard'
+# 'qt5-wayland'
+# 'qt5-webchannel'
+# 'qt5-webengine'
+# 'qt5-webglplugin'
+# 'qt5-webkit'
+# 'qt5-websockets'
+# 'qt5-webview'
+# 'qt5-x11extras'
+# 'qt5-xmlpatterns'
+ 'sdl_mixer' 'tinyxml')
+
+makedepends=('boost')
+source=(https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
+ pokerth-1.1.2.patch)
+md5sums=('8fd7d7fc7ece17315e58aa3240dd4586'
+ '0ef5541fc6008dfb2521dcab47afb659')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver-rc"
+
+ # ---< required for v1.1.2 >--------------------------------------------------
+ # these changes should be incorporated in next release ~feb-2018
+ patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch"
+ protoc -I=$srcdir/$pkgname-$pkgver-rc/ --cpp_out=$srcdir/$pkgname-$pkgver-rc/src/third_party/protobuf/ $srcdir/$pkgname-$pkgver-rc/pokerth.proto $srcdir/$pkgname-$pkgver-rc/chatcleaner.proto
+
+ # ----------------------------------------------------------------------------
+
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver-rc"
+
+# qmake CONFIG+="client" -spec linux-g++ ${pkgname}.pro
+ /lib64/qt4/bin/qmake CONFIG+="client" ${pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver-rc"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D pokerth "$pkgdir/usr/bin/pokerth"
+ install -D -m644 docs/pokerth.1 "$pkgdir/usr/share/man/man1/pokerth.1"
+ install -D -m644 data/data-copyright.txt "$pkgdir/usr/share/licenses/pokerth/data-copyright.txt"
+ rm -f "$pkgdir/usr/share/pokerth/data/data-copyright.txt"
+}
+
diff --git a/patch.txt b/patch.txt
new file mode 100644
index 000000000000..a34ad61dd48a
--- /dev/null
+++ b/patch.txt
@@ -0,0 +1,14 @@
+--- pokerth-1.1.2-rc/src/config/configfile.cpp 2017-08-16 14:24:03.000000000 +0200
++++ pokerth-1.1.2-rc/src/config/configfile.cpp 2023-09-06 10:40:47.976098929 +0200
+@@ -118,7 +118,10 @@
+
+ #else
+ //define app-dir
+- const char *homePath = getenv("HOME");
++ const char *homePath = getenv("XDG_CONFIG_HOME");
++ if(homePath == NULL) {
++ homePath = getenv("HOME");
++ }
+ if(homePath) {
+ configFileName = homePath;
+ #ifndef ANDROID
diff --git a/refresh.sh b/refresh.sh
new file mode 100644
index 000000000000..77a6a1fe43b1
--- /dev/null
+++ b/refresh.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/bash
+
+# Commands to make a new release
+# Edit PKGBUILD to bump release
+
+echo -ne "\tHave you bumped pkgrel in PKGBUILD? (Y/N) "
+read YN
+if [ "$YN" == "Y" ]
+then
+ makepkg --printsrcinfo > .SRCINFO
+ git add PKGBUILD .SRCINFO
+ if [ -n "$1" ]
+ then
+ echo -ne "\t\tcommitting..."
+ git commit -m "$1"
+ git push
+ echo " done!"
+ else
+ echo -e "\tNo commit message provided"
+ fi
+else
+ echo -e "\tDon't forget to add a commit message to this script!"
+fi \ No newline at end of file
diff --git a/srcinfo b/srcinfo
new file mode 100644
index 000000000000..98dc8622ac7c
--- /dev/null
+++ b/srcinfo
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+makepkg --printsrcinfo PKGBUILD > .SRCINFO \ No newline at end of file