summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktav2018-01-09 12:28:35 +0100
committerblacktav2018-01-09 12:28:35 +0100
commit9dad5a3ada217cab926d032891d800c59b55b5b4 (patch)
tree4dcde74ebb441ad02c5c93d66b18747e77fa9ea2
parent1580562de24d9ba8ca4c6beb6c9b9e622fb50290 (diff)
downloadaur-9dad5a3ada217cab926d032891d800c59b55b5b4.tar.gz
Forgot to stage
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f15e493f0bd..a53e5b1e128d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pokerth
pkgdesc = Client to online Poker game written in C++/QT
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.pokerth.net/
arch = i686
arch = x86_64
@@ -15,8 +15,10 @@ pkgbase = pokerth
depends = qt5-base
depends = sdl_mixer
depends = tinyxml
- source = https://sourceforge.net/projects/pokerth/files/pokerth/1.1.2/pokerth-1.1.2.tar.gz/download
+ source = https://sourceforge.net/projects/pokerth/files/pokerth/1.1.2/pokerth-1.1.2.tar.gz
+ source = pokerth-1.1.2.patch
md5sums = 8fd7d7fc7ece17315e58aa3240dd4586
+ md5sums = 0ef5541fc6008dfb2521dcab47afb659
pkgname = pokerth
diff --git a/PKGBUILD b/PKGBUILD
index 3749b1587750..d6e3ed4d6a51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,39 @@
pkgname=pokerth
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Client to online Poker game written in C++/QT"
arch=('i686' 'x86_64')
url="http://www.pokerth.net/"
license=('GPL' 'custom')
depends=('curl' 'boost-libs' 'gsasl' 'protobuf'
'qt5-base' 'sdl_mixer' 'tinyxml')
+
makedepends=('boost')
-source=(https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz/download)
-md5sums=('8fd7d7fc7ece17315e58aa3240dd4586')
+
+source=(https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
+ ${pkgname}-${pkgver}.patch)
+md5sums=('8fd7d7fc7ece17315e58aa3240dd4586'
+ '0ef5541fc6008dfb2521dcab47afb659')
prepare() {
cd "$srcdir/$pkgname-$pkgver-rc"
# ---< required for v1.1.2 >--------------------------------------------------
# these changes should be incorporated in next release ~feb-2018
-
- # reserved is now a keyword for protobuf v3.5
- sed -i '704s/reserved/custReserved/' pokerth.proto
- sed -i '252s/reserved/custReserved/' src/net/common/netpacket.cpp
- # above then needs protobuf files rebuilt
- protoc -I=$srcdir/$pkgname-$pkgver-rc/ --cpp_out=$srcdir/$pkgname-$pkgver-rc/src/third_party/protobuf/ $srcdir/$pkgname-$pkgver-rc/pokerth.proto $srcdir/$pkgname-$pkgver-rc/chatcleaner.proto
- # clearup ambiguous call error
- sed -i '3862s/advance/std::advance/' src/gui/qt/gametable/gametableimpl.cpp
+ patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch"
# ----------------------------------------------------------------------------
+ # good idea to do this at all times
+ protoc -I=$srcdir/$pkgname-$pkgver-rc/ --cpp_out=$srcdir/$pkgname-$pkgver-rc/src/third_party/protobuf/ $srcdir/$pkgname-$pkgver-rc/pokerth.proto $srcdir/$pkgname-$pkgver-rc/chatcleaner.proto
+
}
build() {
cd "$srcdir/$pkgname-$pkgver-rc"
- qmake CONFIG+="client" -spec linux-g++ ${pkgname}.pro
+ # QMAKE_CFLAGS_ISYSTEM workaround to prevent generation of "-isystem /usr/include"
+ qmake CONFIG+="client" QMAKE_CFLAGS_ISYSTEM= -spec linux-g++ ${pkgname}.pro
make
}
@@ -48,3 +49,4 @@ package() {
install -D -m644 data/data-copyright.txt "$pkgdir/usr/share/licenses/pokerth/data-copyright.txt"
rm -f "$pkgdir/usr/share/pokerth/data/data-copyright.txt"
}
+