summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktav2020-12-10 15:50:29 +0100
committerblacktav2020-12-10 15:50:29 +0100
commitaaef55a538aa0b433407ef79af9508c0d9ebef08 (patch)
treef804b5960d34c4317122e8628cbaacb4f2df76ac
parent4972e5788f83f0cc20762f62260172216efbb774 (diff)
downloadaur-aaef55a538aa0b433407ef79af9508c0d9ebef08.tar.gz
Added patch for building with boost
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--pokerth-1.1.2.patch.202012
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dca5e929e106..fdbfd8ed855c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pokerth
pkgdesc = Client to online Poker game written in C++/QT
pkgver = 1.1.2
- pkgrel = 14
+ pkgrel = 15
url = http://www.pokerth.net/
arch = i686
arch = x86_64
@@ -18,9 +18,11 @@ pkgbase = pokerth
source = https://sourceforge.net/projects/pokerth/files/pokerth/1.1.2/pokerth-1.1.2.tar.gz
source = pokerth-1.1.2.patch
source = pokerth-1.1.2.patch.2019
+ source = pokerth-1.1.2.patch.2020
md5sums = 8fd7d7fc7ece17315e58aa3240dd4586
md5sums = 0ef5541fc6008dfb2521dcab47afb659
md5sums = 50d427bd8afc57fb61e186de6c4e5601
+ md5sums = e5bf2357733b4508737f8271f3c1e65f
pkgname = pokerth
diff --git a/PKGBUILD b/PKGBUILD
index 7379d2a2bae0..bfd9af2d4617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: blacktav <blacktav at gmail dot com>
# Contributor: based on unknown abandoned pokerth-final from 2012-12-27
+# Patches: xx55tt
pkgname=pokerth
pkgver=1.1.2
-pkgrel=14
+pkgrel=15
pkgdesc="Client to online Poker game written in C++/QT"
arch=('i686' 'x86_64')
url="http://www.pokerth.net/"
@@ -15,10 +16,12 @@ makedepends=('boost')
source=(https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
${pkgname}-${pkgver}.patch
- ${pkgname}-${pkgver}.patch.2019)
+ ${pkgname}-${pkgver}.patch.2019
+ ${pkgname}-${pkgver}.patch.2020)
md5sums=('8fd7d7fc7ece17315e58aa3240dd4586'
'0ef5541fc6008dfb2521dcab47afb659'
- '50d427bd8afc57fb61e186de6c4e5601')
+ '50d427bd8afc57fb61e186de6c4e5601'
+ 'e5bf2357733b4508737f8271f3c1e65f')
prepare() {
cd "$srcdir/$pkgname-$pkgver-rc"
@@ -30,6 +33,10 @@ prepare() {
# changes to permit building with boost 1.70
patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2019"
# ----------------------------------------------------------------------------
+ # change to permit building with boost 1.74
+ # see also DEFINE+="BOOST_BIND_GLOBAL_PLACEHOLDERS" in build below
+ patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2020"
+ # ----------------------------------------------------------------------------
# good idea to do this at all times
protoc -I=$srcdir/$pkgname-$pkgver-rc/ --cpp_out=$srcdir/$pkgname-$pkgver-rc/src/third_party/protobuf/ $srcdir/$pkgname-$pkgver-rc/pokerth.proto $srcdir/$pkgname-$pkgver-rc/chatcleaner.proto
@@ -40,7 +47,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver-rc"
# QMAKE_CFLAGS_ISYSTEM workaround to prevent generation of "-isystem /usr/include"
- qmake CONFIG+="client" QMAKE_CFLAGS_ISYSTEM= -spec linux-g++ ${pkgname}.pro
+ qmake CONFIG+="client" DEFINES+="BOOST_BIND_GLOBAL_PLACEHOLDERS" QMAKE_CFLAGS_ISYSTEM= -spec linux-g++ ${pkgname}.pro
make
}
diff --git a/pokerth-1.1.2.patch.2020 b/pokerth-1.1.2.patch.2020
new file mode 100644
index 000000000000..2d38df62f902
--- /dev/null
+++ b/pokerth-1.1.2.patch.2020
@@ -0,0 +1,12 @@
+--- pokerth-1.1.2-rc/src/net/common/serveracceptwebhelper.cpp
++++ pokerth-1.1.2-rc/src/net/common/serveracceptwebhelper.cpp
+@@ -29,6 +29,8 @@
+ * as that of the covered work. *
+ *****************************************************************************/
+
++#include <boost/bind.hpp>
++
+ #include <net/serveracceptwebhelper.h>
+ #include <net/sessiondata.h>
+ #include <net/webreceivebuffer.h>
+ \ No newline at end of file