summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktav2023-11-17 21:06:33 +0100
committerblacktav2023-11-17 21:06:33 +0100
commited1256f1660a98b00f8f14ac8df07f5df2844f83 (patch)
tree1a4829f3e8ff1fae0dd7af5d508fb321ae63f6b4
parented1f058eda2451ac21b124c6538f9430cabd1d83 (diff)
downloadaur-ed1256f1660a98b00f8f14ac8df07f5df2844f83.tar.gz
patch revision updated this time
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--pokerth-1.1.2.patch.202324
3 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c3e2b12b1a7..f906cffd2801 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pokerth
pkgdesc = Client to online Poker game written in C++/Qt
pkgver = 1.1.2
- pkgrel = 31
+ pkgrel = 32
url = http://www.pokerth.net/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 0c84da1a1cc0..e810a7ffe70b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pokerth
pkgver=1.1.2
-pkgrel=31
+pkgrel=32
pkgdesc="Client to online Poker game written in C++/Qt"
arch=('i686' 'x86_64')
url="http://www.pokerth.net/"
@@ -41,8 +41,9 @@ prepare() {
# see also DEFINE+="BOOST_BIND_GLOBAL_PLACEHOLDERS" in build below
patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2020"
# ----------------------------------------------------------------------------
- # change to explicitly link /usr/lib/libabsl_log_internal_message.so and
- # /usr/lib/libabsl_log_internal_check_op.so
+ # change to explicitly link libabsl_log_internal_message.so and
+ # libabsl_log_internal_check_op.so
+ # patch revised by xx55tt
patch -Np1 -i "${srcdir}/pokerth-1.1.2.patch.2023"
# ----------------------------------------------------------------------------
# change to use XDG_CONFIG_HOME if available
diff --git a/pokerth-1.1.2.patch.2023 b/pokerth-1.1.2.patch.2023
index 96f29eacb714..5cb14137a8ac 100644
--- a/pokerth-1.1.2.patch.2023
+++ b/pokerth-1.1.2.patch.2023
@@ -1,13 +1,13 @@
---- pokerth-1.1.2-rc/pokerth_game.pro 2023-07-04 22:43:50.069300036 +0200
-+++ pokerth-1.1.2-rc/pokerth_game.pro 2023-07-04 23:39:38.849095436 +0200
+--- pokerth-1.1.2-rc/pokerth_game.pro 2023-07-04 22:43:50.069300036 +0200
++++ pokerth-1.1.2-rc/pokerth_game.pro 2023-07-04 23:39:38.849095436 +0200
@@ -524,7 +524,9 @@
- kFreeBSD = $$find(UNAME, "kFreeBSD")
- LIBS += -lsqlite3 \
- -ltinyxml \
-- -lprotobuf
-+ -lprotobuf \
-+ /usr/lib/libabsl_log_internal_message.so \
-+ /usr/lib/libabsl_log_internal_check_op.so
- LIBS += $$BOOST_LIBS
- LIBS += -lSDL \
- -lSDL_mixer \
+ kFreeBSD = $$find(UNAME, "kFreeBSD")
+ LIBS += -lsqlite3 \
+ -ltinyxml \
+- -lprotobuf
++ -lprotobuf \
++ -labsl_log_internal_check_op \
++ -labsl_log_internal_message
+ LIBS += $$BOOST_LIBS
+ LIBS += -lSDL \
+ -lSDL_mixer \ \ No newline at end of file