summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2015-12-24 21:08:12 +0100
committerRicardo (XenGi) Band2015-12-24 21:08:12 +0100
commit33e0892c0b388618e03ae07d0e81d8bfa26c4c71 (patch)
tree573f86d59c4bdc6204e31e8c4603860fb873a5b7
parentdc32c00572b6d798f58038b2cde4607ede67b4b7 (diff)
downloadaur-33e0892c0b388618e03ae07d0e81d8bfa26c4c71.tar.gz
example for integration in fish shell added
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--pokeshell.install14
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce101a9f8241..ccbfb583f168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pokeshell
pkgdesc = Displays pokemons in your shell
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/XenGi/pokeshell
install = pokeshell.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index c92f0270e34f..11d83e2047d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _firstpokemon=1
_lastpokemon=151
pkgname=pokeshell
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Displays pokemons in your shell"
arch=(any)
url="https://github.com/XenGi/pokeshell"
diff --git a/pokeshell.install b/pokeshell.install
index a8fb59a0e3d5..592c94f971a4 100644
--- a/pokeshell.install
+++ b/pokeshell.install
@@ -2,10 +2,24 @@ post_install() {
echo "put something like this at the end of your ~/.bashrc to get a random pokemon on every bash launch:"
echo ""
echo "cat /usr/share/pokeshell/\$((\$RANDOM % 151 + 1)).pokemon"
+ echo ""
+ echo "For fish shell you can add this function to your ~/.config/fish/functions/fish_prompt.fish:"
+ echo ""
+ echo "function fish_greeting"
+ echo " set r (random)"
+ echo " cat /usr/share/pokeshell/(math \"$r % 151 + 1\").pokemon"
+ echo "end"
}
post_upgrade() {
echo "put something like this at the end of your ~/.bashrc to get a random pokemon on every bash launch:"
echo ""
echo "cat /usr/share/pokeshell/\$((\$RANDOM % 151 + 1)).pokemon"
+ echo ""
+ echo "For fish shell you can add this function to your ~/.config/fish/functions/fish_prompt.fish:"
+ echo ""
+ echo "function fish_greeting"
+ echo " set r (random)"
+ echo " cat /usr/share/pokeshell/(math \"$r % 151 + 1\").pokemon"
+ echo "end"
}