summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2020-12-27 01:40:15 +0500
committerVyacheslav Konovalov2020-12-27 01:40:15 +0500
commit1b7db887896d9cff1dafdd6a6450af141a515c38 (patch)
treeecf95ecf0b2b27a207a1fde3d379362a5b76bc67
parent64447fce2bc9a1f807144680fc0575dcb96728cb (diff)
downloadaur-1b7db887896d9cff1dafdd6a6450af141a515c38.tar.gz
Remove redundant makedepends, change npm cache dir
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16e05e748e26..564d0ae396cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=polaris
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc='Music streaming application, designed to let you enjoy your music collection from any computer or mobile device'
arch=('x86_64')
url='https://github.com/agersant/polaris'
license=('MIT')
depends=('openssl' 'sqlite')
-makedepends=('pkgconf' 'cargo' 'npm' 'make')
+makedepends=('cargo' 'npm')
backup=('etc/polaris/config.toml')
source=(
"$url/archive/$pkgver.tar.gz"
@@ -38,8 +38,8 @@ build() {
# Build client
cd "$srcdir/$_webbuild"
# FIX: https://github.com/agersant/polaris-web/issues/66
- npm install @babel/helper-compilation-targets --save-dev
- npm install
+ npm install @babel/helper-compilation-targets --save-dev --cache "$srcdir/npm-cache"
+ npm install --cache "$srcdir/npm-cache"
npm run production
}