summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshtrom2010-11-03 23:21:41 +0000
committerOlivier Mehani2015-07-01 13:20:12 +1000
commit97b4ef3805eedc5f8490363c6052433ac0a8d01b (patch)
tree2b0565f8dcfc5764e3bea4a366018193dea53681
downloadaur-97b4ef3805eedc5f8490363c6052433ac0a8d01b.tar.gz
[poldi] Import 0.4-3 from AUR.
2015-07-01: Force add .SRCINFO to please aur4.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--poldi-arch.patch11
-rw-r--r--poldi.install61
4 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20bf718c2d11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = poldi
+ pkgdesc = PAM module for authentication using a smartcard
+ pkgver = 0.4
+ pkgrel = 3
+ url = http://http://www.g10code.com/p-poldi.html
+ install = poldi.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libgcrypt
+ depends = libgpg-error
+ depends = libksba
+ depends = pam
+ source = ftp://ftp.gnupg.org/gcrypt/alpha/poldi/poldi-0.4.tar.bz2
+ source = poldi-arch.patch
+ md5sums = 5a0312c3124e3dbb558a24f1017c169c
+ md5sums = 3533f7b428e2c9a4bbfff2271ba24e5d
+
+pkgname = poldi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bc9857008c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Peter Lewis <prlewis@letterboxes.org>
+
+pkgname=poldi
+pkgver=0.4
+pkgrel=3
+pkgdesc="PAM module for authentication using a smartcard"
+arch=('i686' 'x86_64')
+url="http://http://www.g10code.com/p-poldi.html"
+license="GPL"
+depends=('libgcrypt' 'libgpg-error' 'libksba' 'pam')
+makedepends=()
+options=()
+backup=()
+install=('poldi.install')
+source=("ftp://ftp.gnupg.org/gcrypt/alpha/poldi/$pkgname-$pkgver.tar.bz2" "poldi-arch.patch")
+md5sums=('5a0312c3124e3dbb558a24f1017c169c' '3533f7b428e2c9a4bbfff2271ba24e5d')
+
+build() {
+
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < ../poldi-arch.patch
+
+ ./configure --prefix=/usr --with-pam-module-directory=/lib/security --sysconfdir="$pkgdir/usr/share/doc/poldi/example_etc"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-conf-skeleton
+
+ mkdir "$pkgdir/lib"
+ mkdir "$pkgdir/lib/security"
+ cp src/pam/pam_poldi.so "$pkgdir/lib/security/"
+
+ rm "$pkgdir/usr/share/info/dir"
+}
diff --git a/poldi-arch.patch b/poldi-arch.patch
new file mode 100644
index 000000000000..25fd848a2a92
--- /dev/null
+++ b/poldi-arch.patch
@@ -0,0 +1,11 @@
+diff -ur poldi-0.4-orig/src/util/support.c poldi-0.4/src/util/support.c
+--- poldi-0.4-orig/src/util/support.c 2008-11-10 11:10:19.000000000 +0000
++++ poldi-0.4/src/util/support.c 2008-11-10 11:10:38.000000000 +0000
+@@ -20,6 +20,7 @@
+
+ #include "util-local.h"
+
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <assert.h>
diff --git a/poldi.install b/poldi.install
new file mode 100644
index 000000000000..262ad7c1bb79
--- /dev/null
+++ b/poldi.install
@@ -0,0 +1,61 @@
+## arg 1: the new package version
+pre_install() {
+ # do nothing here
+ /bin/true
+}
+
+infodir=/usr/share/info
+
+
+## arg 1: the new package version
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+
+ echo "Poldi is now installed."
+ echo
+ echo "Since this is the first time you've installed poldi, the template configuration files have been placed in /etc/poldi. Take a look and edit them to your needs."
+ echo "The original templates will remain in /usr/share/doc/poldi/example_etc/poldi."
+
+ mkdir -p /etc/poldi
+ cp -fR /usr/share/doc/poldi/example_etc/poldi/* /etc/poldi/
+
+ echo
+ echo "Future upgrades to this package will NOT overwrite your configuration files in /etc/poldi, since this might seriously break things. The latest version of the template configuration files can always be found in /usr/share/doc/poldi/example_etc/poldi."
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ # do nothing here
+ /bin/true
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+
+ echo "Poldi has now been upgraded."
+ echo
+ echo "Warning: Upgrades to this package will not replace any configuration files in /etc/poldi, in order to prevent serious logging in problems."
+ echo "The updated sample configuration files are now in /usr/share/doc/poldi/example_etc/poldi. Take a look and update your own files in /etc/poldi if necessary."
+}
+
+## arg 1: the old package version
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+## arg 1: the old package version
+post_remove() {
+ # do nothing here
+ /bin/true
+}
+
+# vim:set ts=2 sw=2 et: