summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-04-03 12:57:04 -0400
committerGI_Jack2018-04-03 12:57:04 -0400
commit7a403d196a886a473b7bde2a484f1c9240bc85b3 (patch)
treed67637ca633e7083953fff60578b696ec1cfc468
downloadaur-7a403d196a886a473b7bde2a484f1c9240bc85b3.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6976e34b78cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Apr 3 16:56:55 UTC 2018
+pkgbase = polenum
+ pkgdesc = A python script to extract the password policy information from a windows machine.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Wh1t3Fox/polenum
+ arch = any
+ license = GPL3
+ depends = impacket
+ depends = python2
+ source = https://github.com/Wh1t3Fox/polenum/archive/1.0.tar.gz
+ sha512sums = 372c7d0394d55ec65bd6e9d003dd7a443b261a23fce2b8ee079ef8f9bc7836dc615b0ea2084ca07a908efadaa7098a86dc9b6c1752ee893616b1a81ae04c9475
+
+pkgname = polenum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cb816c2e8de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+# Poached from Arch Strike
+# Original: ArchStrike <team@archstrike.org>
+
+pkgname=polenum
+pkgver=1.0
+pkgrel=1
+pkgdesc="A python script to extract the password policy information from a windows machine."
+arch=('any')
+url="https://github.com/Wh1t3Fox/polenum"
+license=('GPL3')
+depends=('impacket' 'python2')
+source=("https://github.com/Wh1t3Fox/polenum/archive/1.0.tar.gz")
+sha512sums=('372c7d0394d55ec65bd6e9d003dd7a443b261a23fce2b8ee079ef8f9bc7836dc615b0ea2084ca07a908efadaa7098a86dc9b6c1752ee893616b1a81ae04c9475')
+
+package() {
+ cd "$srcdir/polenum-$pkgver"
+
+ # Base directories.
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/share/licenses/polenum"
+
+ # Bin.
+ install -m755 polenum.py "$pkgdir/usr/bin/polenum"
+
+ # License.
+ install -m644 LICENSE "$pkgdir/usr/share/licenses/polenum"
+}