summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2018-12-26 22:15:56 +0100
committerDavide Depau2018-12-26 22:15:56 +0100
commitab024ed681c70d85130d3ad88b26e9b45809e83a (patch)
tree58af97e26435569c4c623aca03c8afda822a4cd6
downloadaur-ab024ed681c70d85130d3ad88b26e9b45809e83a.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
-rw-r--r--polibeepsync.desktop12
-rw-r--r--polibeepsync.svg78
4 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9415e7539fe0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = polibeepsync-git
+ pkgdesc = Sync Politecnico di Milano's BeeP files with your PC
+ pkgver = 0.4.1.r4.g10808e2
+ pkgrel = 1
+ url = https://jacotsu.github.io/polibeepsync/
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ depends = python-appdirs
+ depends = python-pyside2
+ depends = python-beautifulsoup4
+ depends = python-lxml
+ depends = python-pyparsing
+ depends = python-signalslot
+ depends = python-contexter
+ provides = polibeepsync
+ conflicts = polibeepsync
+ source = git+https://github.com/Jacotsu/polibeepsync.git
+ source = polibeepsync.desktop
+ source = polibeepsync.svg
+ sha512sums = SKIP
+ sha512sums = 2be34458899e0f8cdc7777514226d2e2fb91b70cc5a8f09d632f2958224842335337e5220fca39a7558a855a088c7e109edb8b96606ab6a013a684d055326576
+ sha512sums = faf89d54fc23b61d52773ea321f0f9522f453632a7abf9ee30889732ea808fec7e7ce282aad8d52a917c30a016e889c741f08c51979db0c2721a3383cf973cde
+
+pkgname = polibeepsync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1579f1897c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+_pkgname=polibeepsync
+pkgname="${_pkgname}-git"
+pkgver=0.4.1.r4.g10808e2
+pkgrel=1
+pkgdesc="Sync Politecnico di Milano's BeeP files with your PC"
+arch=('any')
+url='https://jacotsu.github.io/polibeepsync/'
+license=('GPL3')
+depends=('python' 'python-requests' 'python-appdirs' 'python-pyside2' 'python-beautifulsoup4' 'python-lxml' 'python-pyparsing' 'python-signalslot' 'python-contexter')
+makedepends=('git' 'python-setuptools')
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=('git+https://github.com/Jacotsu/polibeepsync.git' "$_pkgname.desktop" "$_pkgname.svg")
+sha512sums=('SKIP'
+ '2be34458899e0f8cdc7777514226d2e2fb91b70cc5a8f09d632f2958224842335337e5220fca39a7558a855a088c7e109edb8b96606ab6a013a684d055326576'
+ 'faf89d54fc23b61d52773ea321f0f9522f453632a7abf9ee30889732ea808fec7e7ce282aad8d52a917c30a016e889c741f08c51979db0c2721a3383cf973cde')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ # Works around a bug in Arch Linux's PySide2 package that makes
+ # the app fail to start
+ sed -i 's/"PySide2",//' setup.py
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+
+ cd "$srcdir"
+ install -D -m644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -D -m644 $_pkgname.svg "$pkgdir/usr/share/pixmaps/$_pkgname.svg"
+}
+
diff --git a/polibeepsync.desktop b/polibeepsync.desktop
new file mode 100644
index 000000000000..7844fbe20f18
--- /dev/null
+++ b/polibeepsync.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Polimi BeeP Sync
+Comment=Sync your BeeP files
+TryExec=polibeepsync
+StartupWMClass=PoliBeepSync
+Terminal=false
+Exec=polibeepsync-gui
+Icon=polibeepsync
+Keywords=polimi;sync;beep
+Categories=Network;Qt;
diff --git a/polibeepsync.svg b/polibeepsync.svg
new file mode 100644
index 000000000000..4453b38983ea
--- /dev/null
+++ b/polibeepsync.svg
@@ -0,0 +1,78 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="48"
+ height="48"
+ viewBox="0 0 12.7 12.7"
+ version="1.1"
+ id="svg8"
+ inkscape:version="0.92.2 2405546, 2018-03-11"
+ sodipodi:docname="polibeepsync.svg">
+ <defs
+ id="defs2" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="8.0871259"
+ inkscape:cx="22.283935"
+ inkscape:cy="25.637954"
+ inkscape:document-units="mm"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ units="px"
+ inkscape:window-width="2560"
+ inkscape:window-height="1311"
+ inkscape:window-x="0"
+ inkscape:window-y="55"
+ inkscape:window-maximized="1" />
+ <metadata
+ id="metadata5">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Layer 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(0,-284.29998)">
+ <g
+ id="g4549"
+ transform="matrix(2.7456451,0,0,2.7456451,-433.69559,-199.06116)">
+ <path
+ inkscape:connector-curvature="0"
+ id="circle3734"
+ transform="scale(0.26458333)"
+ d="m 607.78711,666.39258 a 5.6571394,5.6571394 0 0 0 -5.6582,5.6582 5.6571394,5.6571394 0 0 0 5.6582,5.65625 5.6571394,5.6571394 0 0 0 5.65625,-5.65625 5.6571394,5.6571394 0 0 0 -5.65625,-5.6582 z m 0,2.04101 a 3.6168597,3.6168597 0 0 1 3.61719,3.61719 3.6168597,3.6168597 0 0 1 -3.61719,3.61719 3.6168597,3.6168597 0 0 1 -3.61719,-3.61719 3.6168597,3.6168597 0 0 1 3.61719,-3.61719 z"
+ style="opacity:1;fill:#80c1c2;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:0;stroke-linecap:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
+ <path
+ inkscape:connector-curvature="0"
+ id="path3728"
+ d="m 159.69795,179.67006 a 0.73203415,0.73203415 0 0 1 -0.73204,0.73203 0.73203415,0.73203415 0 0 1 -0.73203,-0.73203 0.73203415,0.73203415 0 0 1 0.73203,-0.73203 0.73203415,0.73203415 0 0 1 0.73204,0.73203 z"
+ style="opacity:1;fill:#e47358;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:0;stroke-linecap:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
+ <path
+ inkscape:connector-curvature="0"
+ id="path3730"
+ d="m 161.3215,177.81339 a 0.51119703,0.51119703 0 0 1 -0.5112,0.51119 0.51119703,0.51119703 0 0 1 -0.51119,-0.51119 0.51119703,0.51119703 0 0 1 0.51119,-0.5112 0.51119703,0.51119703 0 0 1 0.5112,0.5112 z"
+ style="opacity:1;fill:#80c1c2;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:0;stroke-linecap:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
+ </g>
+ </g>
+</svg>