summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-05-26 18:41:56 +0200
committerNicolas Iooss2018-05-26 18:41:56 +0200
commitf46279aa1c1dcdeacfab9f92c68c463bf7c5e0c9 (patch)
tree3f27dc86cd76cbe7efa50a492089768d8e6bb0a8
parentf361dbf3ab004aa058e49fd6d06ed37aacf77b79 (diff)
downloadaur-f46279aa1c1dcdeacfab9f92c68c463bf7c5e0c9.tar.gz
policycoreutils 2.8-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82f7e1b6c5b2..6ee3ba6177e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = policycoreutils
pkgdesc = SELinux policy core utilities
- pkgver = 2.7
+ pkgver = 2.8
pkgrel = 1
url = http://userspace.selinuxproject.org
arch = i686
@@ -16,10 +16,10 @@ pkgbase = policycoreutils
optdepends = selinux-python: Python tools and libraries for SELinux
optdepends = selinux-sandbox: sandboxing tool for SELinux
optdepends = semodule-utils: SELinux module tools
- provides = selinux-usr-policycoreutils=2.7-1
+ provides = selinux-usr-policycoreutils=2.8-1
conflicts = selinux-usr-policycoreutils
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/policycoreutils-2.7.tar.gz
- sha256sums = 0a1b8a4a323b854981c6755ff025fe98a0f1cff307f109abb260f0490f13e4f4
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/policycoreutils-2.8.tar.gz
+ sha256sums = 986553a235f27bee7ad7c2b7c35ea51eb2ee68e2cf03b661b1585de101bc1099
pkgname = policycoreutils
diff --git a/PKGBUILD b/PKGBUILD
index 19410f90536a..59f9f99575c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,12 @@
# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
# Contributor: angelux/xangelux (xangelux <at> gmail <dot> com)
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgname=policycoreutils
-pkgver=2.7
+pkgver=2.8
pkgrel=1
pkgdesc="SELinux policy core utilities"
arch=('i686' 'x86_64')
@@ -22,20 +25,15 @@ optdepends=('mcstrans: SELinux MCS translation daemon'
'semodule-utils: SELinux module tools')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('0a1b8a4a323b854981c6755ff025fe98a0f1cff307f109abb260f0490f13e4f4')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('986553a235f27bee7ad7c2b7c35ea51eb2ee68e2cf03b661b1585de101bc1099')
build() {
cd "${pkgname}-${pkgver}"
-
make LSPP_PRIV=y all
}
package() {
cd "${pkgname}-${pkgver}"
-
- make DESTDIR="${pkgdir}" \
- LIBEXECDIR="${pkgdir}/usr/lib" \
- SBINDIR="${pkgdir}/usr/bin" \
- install
+ make DESTDIR="${pkgdir}" LIBEXECDIR=/usr/lib SBINDIR=/usr/bin install
}