summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyperdriveguy2020-05-11 22:21:01 -0700
committerHyperdriveguy2020-05-11 22:21:01 -0700
commit0140c2fa8b822191f582511a5d3be19b9782fe90 (patch)
tree05ffcbba7c0745f63629fcb9d33c98f86993e6f5
downloadaur-0140c2fa8b822191f582511a5d3be19b9782fe90.tar.gz
Add initial PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7b45b26cb99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = polished-map-plus-plus
+ pkgdesc = A map and tileset editor for pokecrystal, pokered, and hacks based on them like Polished Crystal (attributes support).
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/Rangi42/polished-map
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ depends = fltk-mod
+ source = polished-map-plus-plus::git+https://github.com/Rangi42/polished-map.git
+ sha256sums = SKIP
+
+pkgname = polished-map-plus-plus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0195678e655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hyperdriveguy <hyperdriveguy@gmail.com>
+pkgname=polished-map-plus-plus
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="A map and tileset editor for pokecrystal, pokered, and hacks based on them like Polished Crystal (attributes support)."
+arch=('x86_64')
+url='https://github.com/Rangi42/polished-map'
+license=('LGPL')
+depends=('fltk-mod')
+makedepends=('git' 'make' 'gcc')
+source=("${pkgname}"::'git+https://github.com/Rangi42/polished-map.git')
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ git checkout ff48bf6
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}