summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreplabrobin2015-08-16 20:23:22 +0100
committerreplabrobin2015-08-16 20:23:22 +0100
commit0e0a36a7ab7616f920598689fee8aa036d3f8e07 (patch)
treee3496b5f1d69853c086e6c25cd4175a1c116a625
downloadaur-0e0a36a7ab7616f920598689fee8aa036d3f8e07.tar.gz
cloned from old aur http://pkgbuild.com/git/aur-mirror.git/
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
-rw-r--r--polkit.install18
-rw-r--r--polkit.pam7
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0423c38e2f7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = polkit-consolekit
+ pkgdesc = PolyciKit with ConsoleKit support for non-systemd systems
+ pkgver = 0.112
+ pkgrel = 2
+ url = http://www.freedesktop.org/wiki/Software/polkit
+ install = polkit.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ depends = glib2
+ depends = pam
+ depends = expat
+ depends = js185
+ provides = polkit=0.112
+ conflicts = polkit
+ options = !libtool
+ source = http://www.freedesktop.org/software/polkit/releases/polkit-0.112.tar.gz
+ source = polkit.pam
+ md5sums = b0f2fa00a55f47c6a5d88e9b73f80127
+ md5sums = 6564f95878297b954f0572bc1610dd15
+
+pkgname = polkit-consolekit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0523ca3c30e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: kozec <kozec at kozec.com>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=polkit-consolekit
+pkgver=0.112
+pkgrel=2
+pkgdesc="PolyciKit with ConsoleKit support for non-systemd systems"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://www.freedesktop.org/wiki/Software/polkit"
+depends=('glib2' 'pam' 'expat' 'js185')
+makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
+provides=("polkit=$pkgver")
+conflicts=('polkit')
+options=('!libtool')
+install=polkit.install
+source=(http://www.freedesktop.org/software/polkit/releases/polkit-$pkgver.tar.gz
+ polkit.pam)
+
+build() {
+ cd "$srcdir/polkit-$pkgver"
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib/polkit-1 \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --enable-libsystemd-login=no \
+ --disable-static --enable-gtk-doc
+ make
+}
+
+package() {
+ cd "$srcdir/polkit-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ chown 102 "$pkgdir/etc/polkit-1/rules.d"
+ chown 102 "$pkgdir/usr/share/polkit-1/rules.d"
+
+ install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
+}
+
+md5sums=('b0f2fa00a55f47c6a5d88e9b73f80127'
+ '6564f95878297b954f0572bc1610dd15')
diff --git a/polkit.install b/polkit.install
new file mode 100644
index 000000000000..fbb98919ed25
--- /dev/null
+++ b/polkit.install
@@ -0,0 +1,18 @@
+post_install() {
+ getent group polkitd >/dev/null || groupadd -g 102 polkitd
+ getent passwd polkitd >/dev/null || useradd -c 'Policy Kit Daemon' -u 102 -g polkitd -d '/' -s /bin/false polkitd
+ passwd -l polkitd &>/dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if getent passwd polkitd >/dev/null; then
+ userdel polkitd
+ fi
+ if getent group polkitd >/dev/null; then
+ groupdel polkitd
+ fi
+}
diff --git a/polkit.pam b/polkit.pam
new file mode 100644
index 000000000000..04f53e0dbc13
--- /dev/null
+++ b/polkit.pam
@@ -0,0 +1,7 @@
+auth requisite pam_nologin.so
+auth required pam_env.so
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_limits.so
+session required pam_unix.so
+password required pam_unix.so