summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-09-12 18:39:35 +0200
committerMartin T. H. Sandsmark2020-09-12 18:39:35 +0200
commitbaf98a18762a96ffd5144815657229dd11308711 (patch)
tree72702f256983be3dfd816ad58294b85498732c5a
downloadaur-baf98a18762a96ffd5144815657229dd11308711.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c076a8f337a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = polkit-dumb-agent-git
+ pkgdesc = A polkit agent in 145 lines of code using Qt and libsystemd, because polkit sucks.
+ pkgver = r15.bf4bef0
+ pkgrel = 1
+ url = https://github.com/sandsmark/polkit-dumb-agent
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = kdesu
+ depends = systemd
+ provides = polkit-dumb-agent
+ conflicts = polkit-dumb-agent
+ source = git+https://github.com/sandsmark/polkit-dumb-agent.git
+ md5sums = SKIP
+
+pkgname = polkit-dumb-agent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4cebfaa4b19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+pkgname=polkit-dumb-agent-git
+pkgver=r15.bf4bef0
+pkgrel=1
+pkgdesc="A polkit agent in 145 lines of code using Qt and libsystemd, because polkit sucks."
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/polkit-dumb-agent"
+license=(GPL3)
+depends=(qt5-base kdesu systemd)
+makedepends=(git)
+provides=(polkit-dumb-agent)
+conflicts=(polkit-dumb-agent)
+source=('git+https://github.com/sandsmark/polkit-dumb-agent.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd polkit-dumb-agent
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../polkit-dumb-agent \
+ -DCMAKE_BUILD_TYPE=Debug \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}