summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 15:33:32 -0600
committerBrian Bidulock2015-06-10 15:33:32 -0600
commitfa3e2e74e8da040429332ecc468b29e9e44ef0cc (patch)
treee13ab1f4ea6bc80da8738af31a8461e992094b16
downloadaur-fa3e2e74e8da040429332ecc468b29e9e44ef0cc.tar.gz
initial version
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD47
-rw-r--r--polkit.install18
-rw-r--r--polkit.pam7
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1abf6ad090cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = polkit-git
+ pkgdesc = Application development toolkit for controlling system-wide privileges
+ pkgver = 0.112.r33.g8277d89
+ pkgrel = 1
+ epoch = 1
+ url = http://www.freedesktop.org/wiki/Software/polkit
+ install = polkit.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ makedepends = git
+ depends = glib2
+ depends = pam
+ depends = expat
+ depends = systemd
+ depends = js17
+ provides = polkit
+ conflicts = polkit
+ source = polkit-git::git+http://anongit.freedesktop.org/git/polkit.git
+ source = polkit.pam
+ md5sums = SKIP
+ md5sums = 6564f95878297b954f0572bc1610dd15
+
+pkgname = polkit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8736894a406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# $Id: PKGBUILD 210524 2014-04-14 20:07:24Z jgc $
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Aline Freitas <aline@alinefreitas.com.br>
+
+pkgname=polkit-git
+pkgver=0.112.r33.g8277d89
+pkgrel=1
+epoch=1
+pkgdesc="Application development toolkit for controlling system-wide privileges"
+arch=(i686 x86_64)
+license=(LGPL)
+url="http://www.freedesktop.org/wiki/Software/polkit"
+depends=(glib2 pam expat systemd js17)
+makedepends=(intltool gtk-doc gobject-introspection git)
+install=polkit.install
+provides=('polkit')
+conflicts=('polkit')
+source=($pkgname::git+http://anongit.freedesktop.org/git/polkit.git
+ polkit.pam)
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long|sed -r 's,([^-]*-g),r\1,;s,-,.,g'
+}
+
+build() {
+ cd $pkgname
+
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib/polkit-1 \
+ --enable-libsystemd-login=yes --disable-static \
+ --enable-gtk-doc --with-mozjs=mozjs-17.0
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+
+ chown 102 "$pkgdir/etc/polkit-1/rules.d"
+ chown 102 "$pkgdir/usr/share/polkit-1/rules.d"
+
+ install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
+}
+md5sums=('SKIP'
+ '6564f95878297b954f0572bc1610dd15')
diff --git a/polkit.install b/polkit.install
new file mode 100644
index 000000000000..fbb98919ed25
--- /dev/null
+++ b/polkit.install
@@ -0,0 +1,18 @@
+post_install() {
+ getent group polkitd >/dev/null || groupadd -g 102 polkitd
+ getent passwd polkitd >/dev/null || useradd -c 'Policy Kit Daemon' -u 102 -g polkitd -d '/' -s /bin/false polkitd
+ passwd -l polkitd &>/dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if getent passwd polkitd >/dev/null; then
+ userdel polkitd
+ fi
+ if getent group polkitd >/dev/null; then
+ groupdel polkitd
+ fi
+}
diff --git a/polkit.pam b/polkit.pam
new file mode 100644
index 000000000000..04f53e0dbc13
--- /dev/null
+++ b/polkit.pam
@@ -0,0 +1,7 @@
+auth requisite pam_nologin.so
+auth required pam_env.so
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_limits.so
+session required pam_unix.so
+password required pam_unix.so