summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2018-10-19 12:39:53 -0400
committerFlaviu Tamas2018-10-19 12:45:40 -0400
commitf86f8b2e58c72f36cdff361796ad47d8c6b9c16b (patch)
tree2aa9ce9cc54cb34c5facc4158a33d8d14c2bc881
downloadaur-f86f8b2e58c72f36cdff361796ad47d8c6b9c16b.tar.gz
Add pkgbuild
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..450e2ab7f99f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = polkit-qt4
+ pkgdesc = A library that allows developers to access PolicyKit API with a nice Qt-style API
+ pkgver = 0.112.0+git20180107
+ pkgrel = 1
+ url = https://www.kde.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = polkit
+ makedepends = qt4
+ makedepends = git
+ depends = polkit
+ depends = qt4
+ source = polkit-qt4::git+https://anongit.kde.org/polkit-qt-1.git#commit=cbecf60ac7b5c17cf37503d6675bf5542efbab29
+ sha256sums = SKIP
+
+pkgname = polkit-qt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b728e3913cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Flaviu Tamas <me@flaviutamas.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=polkit-qt4
+pkgver=0.112.0+git20180107
+pkgrel=1
+pkgdesc='A library that allows developers to access PolicyKit API with a nice Qt-style API'
+arch=(x86_64)
+url='https://www.kde.org/'
+license=(LGPL)
+depends=(polkit qt4)
+makedepends=(cmake polkit qt4 git)
+#source=("http://download.kde.org/stable/apps/KDE4.x/admin/${pkgbase}-1-${pkgver}.tar.bz2")
+source=("$pkgname"::"git+https://anongit.kde.org/polkit-qt-1.git#commit=cbecf60ac7b5c17cf37503d6675bf5542efbab29")
+sha256sums=('SKIP')
+
+build() {
+ mkdir -p "$pkgname/build"
+ cd "$pkgname/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_DESTINATION=/usr/lib \
+ -DUSE_QT4=ON
+ make
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir" install
+}