summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-07-02 20:09:15 -0700
committerxiota2023-07-02 20:09:15 -0700
commit4ed962624f2af7b70cdc66eace317f927080cd08 (patch)
treef3d712fc9f813cb44d57aa7e33f15ac7efc6c147
parent5133d94aa5757a2aa0eff927a3047b80410d395e (diff)
downloadaur-polkit-qt5-git.tar.gz
update pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD36
-rw-r--r--README.md2
-rw-r--r--UNLICENSE24
5 files changed, 25 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 720c21c02d67..ff9d97c71314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = polkit-qt5-git
pkgdesc = A library that allows developers to access PolicyKit API with a nice Qt-style API
- pkgver = v0.114.0.r13.g590e710
+ pkgver = 0.114.0.r13.g590e710
pkgrel = 1
url = https://invent.kde.org/libraries/polkit-qt-1
arch = i686
@@ -12,7 +12,7 @@ pkgbase = polkit-qt5-git
depends = qt5-base
provides = polkit-qt5
conflicts = polkit-qt5
- source = polkit-qt5::git+https://invent.kde.org/libraries/polkit-qt-1.git
+ source = polkit-qt5::git+https://invent.kde.org/libraries/polkit-qt-1
sha256sums = SKIP
pkgname = polkit-qt5-git
diff --git a/.gitignore b/.gitignore
index 40a8f7b65ef1..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
-/pkg/
-/src/
-/*.tar*
-/polkit-qt5/
-
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index c8dd43faf9ed..0f2a7f7faa20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,42 @@
-# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+# Maintainer:
+# Contributor: Dāvis Mosāns <davispuh at gmail dot com>
-_pkgname=polkit-qt5
-pkgname=$_pkgname-git
-pkgver=v0.114.0.r13.g590e710
+_pkgname="polkit-qt5"
+pkgname="$_pkgname-git"
+pkgver=0.114.0.r13.g590e710
pkgrel=1
pkgdesc='A library that allows developers to access PolicyKit API with a nice Qt-style API'
arch=('i686' 'x86_64')
url='https://invent.kde.org/libraries/polkit-qt-1'
license=('LGPL')
+
depends=('polkit' 'qt5-base')
makedepends=('git' 'cmake')
+
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://invent.kde.org/libraries/polkit-qt-1.git")
+
+source=("$_pkgname"::"git+$url")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir"
- mkdir -p build
+ cd "$srcdir"
+ mkdir -p build
}
build() {
- cd "$srcdir/build"
- cmake "$srcdir/$_pkgname" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_DESTINATION=/usr/lib
- make
+ cmake -B build -S "$_pkgname" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_DESTINATION=/usr/lib
+ cmake --build build
}
package() {
- cd "$srcdir/build"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}
diff --git a/README.md b/README.md
deleted file mode 100644
index ec9f6381e152..000000000000
--- a/README.md
+++ /dev/null
@@ -1,2 +0,0 @@
-# polkit-qt5-git
-
diff --git a/UNLICENSE b/UNLICENSE
deleted file mode 100644
index 68a49daad8ff..000000000000
--- a/UNLICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <http://unlicense.org/>