summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-11-05 15:59:04 +0200
committerDāvis2015-11-05 15:59:04 +0200
commit70b3cdb3d4ae745a582c5a79ee885f46932b8765 (patch)
treefacb4eb753558b3a3e9082fa2d3a346c177520a2
downloadaur-70b3cdb3d4ae745a582c5a79ee885f46932b8765.tar.gz
Release polkit-qt5-git
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--README.md2
-rw-r--r--UNLICENSE24
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..812f7ae59fba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = polkit-qt5-git
+ pkgdesc = A library that allows developers to access PolicyKit API with a nice Qt-style API
+ pkgver = v0.112.0.r2.g3882e11
+ pkgrel = 1
+ url = https://projects.kde.org/projects/kdesupport/polkit-qt-1
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = polkit
+ depends = qt5-base
+ provides = polkit-qt5
+ conflicts = polkit-qt5
+ source = polkit-qt5::git+git://anongit.kde.org/polkit-qt-1.git
+ sha256sums = SKIP
+
+pkgname = polkit-qt5-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..40a8f7b65ef1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/polkit-qt5/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcb117645ea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=polkit-qt5
+pkgname=$_pkgname-git
+pkgver=v0.112.0.r2.g3882e11
+pkgrel=1
+pkgdesc='A library that allows developers to access PolicyKit API with a nice Qt-style API'
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kdesupport/polkit-qt-1'
+license=('LGPL')
+depends=('polkit' 'qt5-base')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+git://anongit.kde.org/polkit-qt-1.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/build"
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_DESTINATION=/usr/lib
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..ec9f6381e152
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# polkit-qt5-git
+
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>