summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:38:10 +0200
committerSanskritFritz2015-06-14 00:38:10 +0200
commit4dffb4fb577bf89cb964927f141ab1ff510ee1a0 (patch)
treee925bd7af1c58e2943cd3515b3434b6af5341c66
downloadaur-4dffb4fb577bf89cb964927f141ab1ff510ee1a0.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
-rw-r--r--lGLU.patch10
-rw-r--r--polly-b-gone.desktop10
-rw-r--r--polly-b-gone.pngbin0 -> 5350 bytes
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6025b3ca0504
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = polly-b-gone
+ pkgdesc = 3D physics platform game that tells the story of a plucky wheeled robot named Poll
+ pkgver = 1.0
+ pkgrel = 7
+ url = http://cs.stanford.edu/people/mbostock/polly/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = freeglut
+ depends = glew
+ depends = libgl
+ source = http://danym.org/archlinux/files/polly-src.tar.bz2
+ source = polly-b-gone.png
+ source = polly-b-gone.desktop
+ source = lGLU.patch
+ md5sums = a6075c233fcc5a3c0bbf5d9f16683bdc
+ md5sums = e7d7277f263b4f9c5d6cd0032555f591
+ md5sums = 086ab9c4274900488530cc2e70514a19
+ md5sums = 9c94fd547535ee7e5280eae2042508a7
+
+pkgname = polly-b-gone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c10cd195206e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Dany Martineau <dany.luc.martineau gmail com>
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=polly-b-gone
+pkgver=1.0
+pkgrel=7
+pkgdesc="3D physics platform game that tells the story of a plucky wheeled robot named Poll"
+arch=('i686' 'x86_64')
+url="http://cs.stanford.edu/people/mbostock/polly/"
+license=('LGPL')
+depends=('sdl_mixer' 'sdl_image' 'freeglut' 'glew' 'libgl')
+source=('http://danym.org/archlinux/files/polly-src.tar.bz2' \
+ 'polly-b-gone.png' 'polly-b-gone.desktop' 'lGLU.patch')
+
+build() {
+ cd "${srcdir}/polly-src"
+ patch -p1 < "${srcdir}/lGLU.patch"
+ make
+}
+
+package() {
+ cd "${srcdir}/polly-src"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
+ mkdir -p "${pkgdir}/usr/share/polly"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -R Contents "${pkgdir}/usr/share/polly"
+ cp Polly-B-Gone "${pkgdir}/usr/share/polly/"
+ echo "#!/bin/bash" > "${pkgdir}/usr/bin/polly.sh"
+ echo "cd '/usr/share/polly/' && ./Polly-B-Gone" >> "${pkgdir}/usr/bin/polly.sh"
+ chmod +x "${pkgdir}/usr/bin/polly.sh"
+ install "${srcdir}/polly-b-gone.png" "${pkgdir}/usr/share/pixmaps"
+ install "${srcdir}/polly-b-gone.desktop" "${pkgdir}/usr/share/applications"
+}
+
+md5sums=('a6075c233fcc5a3c0bbf5d9f16683bdc'
+ 'e7d7277f263b4f9c5d6cd0032555f591'
+ '086ab9c4274900488530cc2e70514a19'
+ '9c94fd547535ee7e5280eae2042508a7')
diff --git a/lGLU.patch b/lGLU.patch
new file mode 100644
index 000000000000..e068c8d2a83e
--- /dev/null
+++ b/lGLU.patch
@@ -0,0 +1,10 @@
+--- a/Makefile 2012-12-10 22:13:21.627071916 +0100
++++ b/Makefile 2012-12-10 22:13:07.724246589 +0100
+@@ -5,6 +5,7 @@
+
+ LDFLAGS = \
+ -lGL \
++ -lGLU \
+ -lGLEW \
+ -lglut \
+ `pkg-config sdl --libs` \
diff --git a/polly-b-gone.desktop b/polly-b-gone.desktop
new file mode 100644
index 000000000000..0284809dc242
--- /dev/null
+++ b/polly-b-gone.desktop
@@ -0,0 +1,10 @@
+
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Polly-B-Gone
+GenericName=Polly-B-Gone
+Comment=3D physics platform game that tells the story of a plucky wheeled robot named Poll.
+Exec=/usr/bin/polly.sh
+Categories=Game;ArcadeGame;
+Icon=/usr/share/pixmaps/polly-b-gone.png \ No newline at end of file
diff --git a/polly-b-gone.png b/polly-b-gone.png
new file mode 100644
index 000000000000..cffcd3e5aa8c
--- /dev/null
+++ b/polly-b-gone.png
Binary files differ