summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFinn2023-10-23 17:30:06 +0100
committerFinn2023-10-23 17:30:06 +0100
commitd6b83809743c3b36fa5abc63d2dc8ed2ad405699 (patch)
tree8837d08dfe21e8e0bee473a6ace27b8a3bcc6b3f
parenta92fd1058099b6d423a37d1220608a76c960ed3a (diff)
downloadaur-d6b83809743c3b36fa5abc63d2dc8ed2ad405699.tar.gz
Pull changes from prism to fix build on qt 6.6
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b48907612a2c..0ddc2cda9593 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pollymc
pkgdesc = Prism Launcher fork that adds Ely.by support and allows you to use offline mode without an account.
pkgver = 7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fn2006/PollyMC
arch = i686
arch = x86_64
@@ -31,6 +31,8 @@ pkgbase = pollymc
optdepends = xorg-xrandr: for older minecraft versions
conflicts = prismlauncher
source = https://github.com/fn2006/PollyMC/releases/download/7.2/PollyMC-7.2.tar.gz
+ source = https://aur.archlinux.org/cgit/aur.git/plain/0001-fix-Fix-building-prismlauncher-7.2-on-Qt-6.6.0.patch?h=prismlauncher
sha256sums = 293042eead9d61f5a5be3277cd35d6048bee104099ca6ff5107712e3796631e1
+ sha256sums = 407162bb56d08c7f825632ce486bde8ab03dbceac0a0669ea751f475a1947306
pkgname = pollymc
diff --git a/PKGBUILD b/PKGBUILD
index 12534b1cd008..4396a753f5f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=pollymc
pkgver=7.2
-pkgrel=1
+pkgrel=2
pkgdesc="Prism Launcher fork that adds Ely.by support and allows you to use offline mode without an account."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/fn2006/PollyMC"
@@ -21,8 +21,15 @@ optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
'xorg-xrandr: for older minecraft versions')
-source=("https://github.com/fn2006/PollyMC/releases/download/${pkgver}/PollyMC-${pkgver}.tar.gz")
-sha256sums=('293042eead9d61f5a5be3277cd35d6048bee104099ca6ff5107712e3796631e1')
+source=("https://github.com/fn2006/PollyMC/releases/download/${pkgver}/PollyMC-${pkgver}.tar.gz"
+ "https://aur.archlinux.org/cgit/aur.git/plain/0001-fix-Fix-building-prismlauncher-7.2-on-Qt-6.6.0.patch?h=prismlauncher")
+sha256sums=('293042eead9d61f5a5be3277cd35d6048bee104099ca6ff5107712e3796631e1'
+ '407162bb56d08c7f825632ce486bde8ab03dbceac0a0669ea751f475a1947306')
+
+prepare() {
+ cd "PollyMC-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-fix-Fix-building-prismlauncher-7.2-on-Qt-6.6.0.patch?h=prismlauncher"
+}
build() {
cd "PollyMC-${pkgver}"