summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfn20062022-09-24 16:38:20 +0100
committerfn20062022-09-24 16:38:20 +0100
commit402744f179f0a7b86a2df45bdf42a8d3503a4a7f (patch)
treef535632eab9d4b9321313621d433156f6419656e
downloadaur-402744f179f0a7b86a2df45bdf42a8d3503a4a7f.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD25
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..656bfddfcf4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pollymc-qt5-bin
+ pkgdesc = Minecraft launcher with ability to manage multiple instances.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://github.com/fn2006/PollyMC
+ arch = x86_64
+ license = GPL3
+ depends = java-runtime
+ depends = libgl
+ depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-imageformats
+ depends = zlib
+ depends = hicolor-icon-theme
+ optdepends = java-runtime=8: support for Minecraft versions < 1.17
+ optdepends = java-runtime=17: support for Minecraft versions >= 1.17
+ provides = pollymc
+ provides = pollymc-qt5
+ conflicts = pollymc
+ conflicts = pollymc-qt5
+ noextract = PollyMC-Linux-1.4.2.tar.gz
+ source = https://github.com/fn2006/PollyMC/releases/download/1.4.2/PollyMC-Linux-1.4.2.tar.gz
+ sha256sums = fe7a5221f361e53562f75a1ba23963845a65d4eec7b46afc6507da158c2d041d
+
+pkgname = pollymc-qt5-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e33b04b624d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: fn2006 <usernamefn2006alreadyused@protonmail.com>
+# Contributor: Lenny McLennington <lenny@sneed.church>
+# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
+
+pkgname=pollymc-qt5-bin
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Minecraft launcher with ability to manage multiple instances."
+arch=('x86_64')
+url="https://github.com/fn2006/PollyMC"
+license=('GPL3')
+depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme')
+provides=('pollymc' 'pollymc-qt5')
+conflicts=('pollymc' 'pollymc-qt5')
+optdepends=('java-runtime=8: support for Minecraft versions < 1.17'
+ 'java-runtime=17: support for Minecraft versions >= 1.17')
+source=("https://github.com/fn2006/PollyMC/releases/download/${pkgver}/PollyMC-Linux-${pkgver}.tar.gz")
+noextract=("PollyMC-Linux-${pkgver}.tar.gz")
+sha256sums=('fe7a5221f361e53562f75a1ba23963845a65d4eec7b46afc6507da158c2d041d')
+
+package() {
+ install -d "$pkgdir/usr"
+ tar -C "$pkgdir/usr" -xvf PollyMC-Linux-${pkgver}.tar.gz
+ chown -R root:root "$pkgdir/usr" # fils in tarball are not owned by root
+}