summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-08-13 01:55:43 +0200
committerFabioLolix2018-08-13 01:55:43 +0200
commit645673ef5330b9794b2b7bd4c152cc1634333956 (patch)
treebb166f54d10fb3633965cddf12eb0d83a47759e8
parent8559524a93ae6c276bbc0c2e015994c19b37e089 (diff)
downloadaur-645673ef5330b9794b2b7bd4c152cc1634333956.tar.gz
v18.8
-rwxr-xr-x.SRCINFO11
-rw-r--r--0001-Fixed-build-with-recent-vala-version.patch25
-rw-r--r--0001-Re-add-support-for-vte291-0.52.patch25
-rwxr-xr-xPKGBUILD15
4 files changed, 37 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7c05af32596..065c01c7d810 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = polo
pkgdesc = A modern, light-weight GTK file manager for Linux, currently in beta
- pkgver = 18.6
+ pkgver = 18.8
pkgrel = 1
url = https://teejee2008.github.io/polo/
arch = i686
arch = x86_64
license = GPL2
makedepends = vala
- makedepends = chrpath
depends = gtk3
depends = libgee
depends = libsoup
@@ -27,10 +26,10 @@ pkgbase = polo
provides = polo
conflicts = polo
conflicts = polo-bin
- source = https://github.com/teejee2008/polo/archive/v18.6-beta.tar.gz
- source = 0001-Fixed-build-with-recent-vala-version.patch
- sha256sums = 38ce401f607af3e77b3cd099efc6aea73410361d35771be3563b0f99f147a352
- sha256sums = 97d78f7879eb913dc4b9574e6854553e956f5a883beef2335887d1d12061d0b2
+ source = polo-18.8-beta.tar.gz::https://github.com/teejee2008/polo/archive/v18.8-beta.tar.gz
+ source = 0001-Re-add-support-for-vte291-0.52.patch
+ sha256sums = 1112469c2107ac1ed08d1f2f966d7ee21baff773ff56dc56c137eaef2468515f
+ sha256sums = 4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f
pkgname = polo
diff --git a/0001-Fixed-build-with-recent-vala-version.patch b/0001-Fixed-build-with-recent-vala-version.patch
deleted file mode 100644
index 63a19ac24b48..000000000000
--- a/0001-Fixed-build-with-recent-vala-version.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9ab01270ce389780e3eecb84935c003440befc5a Mon Sep 17 00:00:00 2001
-From: FabioLolix <fabio.lolix@gmail.com>
-Date: Sat, 16 Jun 2018 09:49:13 +0200
-Subject: [PATCH] Fixed build with recent vala version
-
----
- src/Gtk/TermBox.vala | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Gtk/TermBox.vala b/src/Gtk/TermBox.vala
-index a3ed31a..af5d4d1 100644
---- a/src/Gtk/TermBox.vala
-+++ b/src/Gtk/TermBox.vala
-@@ -249,7 +249,7 @@ public class TermBox : Gtk.Box {
- cmd = "%s\n".printf(cmd);
- }
-
-- term.feed_child(cmd, -1);
-+ term.feed_child(cmd.to_utf8());
- }
-
- public void refresh(){
---
-2.17.1
-
diff --git a/0001-Re-add-support-for-vte291-0.52.patch b/0001-Re-add-support-for-vte291-0.52.patch
new file mode 100644
index 000000000000..649704608c31
--- /dev/null
+++ b/0001-Re-add-support-for-vte291-0.52.patch
@@ -0,0 +1,25 @@
+From d73eda26423ef9730eded03c78c636bebe971948 Mon Sep 17 00:00:00 2001
+From: FabioLolix <fabio.lolix@gmail.com>
+Date: Mon, 13 Aug 2018 01:44:37 +0200
+Subject: [PATCH] Re-add support for vte291 >0.52
+
+---
+ src/Gtk/TermBox.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Gtk/TermBox.vala b/src/Gtk/TermBox.vala
+index da5d3a0..0c7b37c 100644
+--- a/src/Gtk/TermBox.vala
++++ b/src/Gtk/TermBox.vala
+@@ -255,7 +255,7 @@ public class TermBox : Gtk.Box {
+
+ #else
+
+- term.feed_child(cmd, -1);
++ term.feed_child(cmd.to_utf8());
+
+ #endif
+ }
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 7fa90b4fccb8..4abd59887f03 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=polo
pkgrel=1
-pkgver=18.6
+pkgver=18.8
_channel=beta
pkgdesc="A modern, light-weight GTK file manager for Linux, currently in beta"
arch=('i686' 'x86_64')
url="https://teejee2008.github.io/polo/"
license=('GPL2')
depends=('gtk3' 'libgee' 'libsoup' 'vte3' 'rsync' 'gvfs' 'p7zip')
-makedepends=('vala' 'chrpath')
+makedepends=('vala')
optdepends=('mediainfo: read media properties from audio and video files'
'fish: terminal shell'
'perl-image-exiftool: read EXIF properties from JPG/TIFF/PNG/PDF files'
@@ -21,14 +21,14 @@ optdepends=('mediainfo: read media properties from audio and video files'
'polo-donation-plugins')
provides=('polo')
conflicts=('polo' 'polo-bin')
-source=("https://github.com/teejee2008/polo/archive/v${pkgver}-${_channel}.tar.gz"
- '0001-Fixed-build-with-recent-vala-version.patch')
-sha256sums=('38ce401f607af3e77b3cd099efc6aea73410361d35771be3563b0f99f147a352'
- '97d78f7879eb913dc4b9574e6854553e956f5a883beef2335887d1d12061d0b2')
+source=("${pkgname}-${pkgver}-${_channel}.tar.gz::https://github.com/teejee2008/polo/archive/v${pkgver}-${_channel}.tar.gz"
+ '0001-Re-add-support-for-vte291-0.52.patch')
+sha256sums=('1112469c2107ac1ed08d1f2f966d7ee21baff773ff56dc56c137eaef2468515f'
+ '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}-${_channel}"
- patch -Np1 -i ../0001-Fixed-build-with-recent-vala-version.patch
+ patch -Np1 -i ../0001-Re-add-support-for-vte291-0.52.patch
}
build() {
@@ -40,7 +40,6 @@ package() {
cd "$srcdir/${pkgname}-${pkgver}-${_channel}"
make DESTDIR="${pkgdir}" install
- chrpath --delete "${pkgdir}"/usr/bin/polo-gtk
ln -s /usr/bin/polo-gtk "${pkgdir}"/usr/bin/polo
rm "${pkgdir}"/usr/bin/polo-uninstall
}