summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-07-11 16:26:20 +0200
committerFabioLolix2017-07-11 16:26:20 +0200
commit583d5c4ce9a9d67f0d6d3b0fb6f301c90df315d2 (patch)
tree8e222d4fa1035f8a34a2cf0cae079f838fa6d39c
parent7beb140db5841181356e476b59135911ab5beb21 (diff)
downloadaur-583d5c4ce9a9d67f0d6d3b0fb6f301c90df315d2.tar.gz
update to 17.7.1 beta 9
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD37
2 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21adeadb07ce..24795a2337cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = polo-donation-plugins
pkgdesc = Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc.
- pkgver = 17.7
+ pkgver = 17.7.1
pkgrel = 1
url = http://www.teejeetech.in/
arch = i686
arch = x86_64
- license = GPL2
depends = polo
provides = polo-donations-plugins
conflicts = polo-donations-plugins
- source_i686 = local://polo-donation-plugins-v17.7-beta.8-i386.deb
- md5sums_i686 = 61df636b4dc16f3196cf54d519f31d6a
- source_x86_64 = local://polo-donation-plugins-v17.7-beta.8-amd64.deb
- md5sums_x86_64 = 5133b8020b51e1b2d4154fd3f4f2d328
+ source_i686 = local://polo-donation-plugins-v17.7.1-beta.9-i386.deb
+ md5sums_i686 = 5b3e980d89c36d40d44c2e78d4cf565f
+ source_x86_64 = local://polo-donation-plugins-v17.7.1-beta.9-amd64.deb
+ md5sums_x86_64 = 8f46d6ad9dc53d8fd65345f42d836fc9
pkgname = polo-donation-plugins
diff --git a/PKGBUILD b/PKGBUILD
index 0d485d7af3c8..6a8abc024b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,41 @@
# https://github.com/FabioLolix
pkgname=polo-donation-plugins
-_betaver=beta.8
-pkgver=17.7
+_channel=beta.9
+pkgver=17.7.1
pkgrel=1
pkgdesc="Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc."
arch=('i686' 'x86_64')
url="http://www.teejeetech.in/"
-license=('GPL2')
+#license=()
depends=('polo')
provides=('polo-donations-plugins')
conflicts=('polo-donations-plugins')
-source_i686=("local://"$pkgname"-v${pkgver}-"$_betaver"-i386.deb")
-source_x86_64=("local://"$pkgname"-v${pkgver}-"$_betaver"-amd64.deb")
-md5sums_i686=('61df636b4dc16f3196cf54d519f31d6a')
-md5sums_x86_64=('5133b8020b51e1b2d4154fd3f4f2d328')
+source_i686=("local://${pkgname}-v${pkgver}-${_channel}-i386.deb")
+source_x86_64=("local://${pkgname}-v${pkgver}-${_channel}-amd64.deb")
+md5sums_i686=('5b3e980d89c36d40d44c2e78d4cf565f')
+md5sums_x86_64=('8f46d6ad9dc53d8fd65345f42d836fc9')
+#options=(emptydirs)
-prepare() {
- cd "${srcdir}"
- tar xzf control.tar.gz
-}
+#prepare() {
+# cd "${srcdir}"
+# tar xzf control.tar.gz
+#}
-pkgver() {
- grep -i "Version" "${srcdir}"/control | cut -d ' ' -f 2
-}
+#pkgver() {
+# grep -i "Version" "${srcdir}"/control | cut -d ' ' -f 2
+#}
package() {
if [[ "${CARCH}" = 'i686' ]]; then
- bsdtar -xf "$pkgname"-v${pkgver}-"$_betaver"-i386.deb
+ bsdtar xf "${pkgname}-v${pkgver}-${_channel}-i386.deb"
fi
if [[ "${CARCH}" = 'x86_64' ]]; then
- bsdtar -xf "$pkgname"-v${pkgver}-"$_betaver"-amd64.deb
+ bsdtar xf "${pkgname}-v${pkgver}-${_channel}-amd64.deb"
fi
bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+
+# install -d $pkgdir/usr/bin
+# ln -s /usr/bin/polo-gtk $pkgdir/usr/bin/polo
+# rm $pkgdir/usr/bin/polo-uninstall
}