summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-09-18 01:42:23 +0200
committerFabioLolix2017-09-18 01:42:23 +0200
commit7bdb0456bff67a692b00036beb28cf07fddf0d9a (patch)
tree51bce68f537fcc84acfe36f02a9c7b06d6f10317
parent583d5c4ce9a9d67f0d6d3b0fb6f301c90df315d2 (diff)
downloadaur-7bdb0456bff67a692b00036beb28cf07fddf0d9a.tar.gz
Updated to version 17.9 beta 10
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD29
3 files changed, 19 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24795a2337cb..ddcfc74707fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = polo-donation-plugins
pkgdesc = Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc.
- pkgver = 17.7.1
+ pkgver = 17.9
pkgrel = 1
url = http://www.teejeetech.in/
arch = i686
arch = x86_64
- depends = polo
+ depends = polo>=17.9
+ depends = youtube-dl
+ depends = pngcrush
+ depends = ghostscript
+ depends = pdftk-bin
provides = polo-donations-plugins
conflicts = polo-donations-plugins
- source_i686 = local://polo-donation-plugins-v17.7.1-beta.9-i386.deb
- md5sums_i686 = 5b3e980d89c36d40d44c2e78d4cf565f
- source_x86_64 = local://polo-donation-plugins-v17.7.1-beta.9-amd64.deb
- md5sums_x86_64 = 8f46d6ad9dc53d8fd65345f42d836fc9
+ source_i686 = local://polo-donation-plugins-v17.9-beta.10-i386.deb
+ md5sums_i686 = 661f3cdd54908c06f59d1e6adb537a42
+ source_x86_64 = local://polo-donation-plugins-v17.9-beta.10-amd64.deb
+ md5sums_x86_64 = e3b069e25d1e693a34db88b66ccffc8c
pkgname = polo-donation-plugins
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index a2b9f39f612a..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,12 +0,0 @@
-*.gz
-*.xz
-*.zip
-*.tar*
-*.tgz
-*.bz2
-*.deb
-*.rpm
-*.run
-pkg
-src
-
diff --git a/PKGBUILD b/PKGBUILD
index 6a8abc024b19..c252e1d67f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,23 @@
# https://github.com/FabioLolix
pkgname=polo-donation-plugins
-_channel=beta.9
-pkgver=17.7.1
+_channel=beta.10
+pkgver=17.9
pkgrel=1
pkgdesc="Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc."
arch=('i686' 'x86_64')
url="http://www.teejeetech.in/"
-#license=()
-depends=('polo')
+depends=('polo>=17.9'
+ 'youtube-dl'
+ 'pngcrush'
+ 'ghostscript'
+ 'pdftk-bin' )
provides=('polo-donations-plugins')
conflicts=('polo-donations-plugins')
source_i686=("local://${pkgname}-v${pkgver}-${_channel}-i386.deb")
source_x86_64=("local://${pkgname}-v${pkgver}-${_channel}-amd64.deb")
-md5sums_i686=('5b3e980d89c36d40d44c2e78d4cf565f')
-md5sums_x86_64=('8f46d6ad9dc53d8fd65345f42d836fc9')
-#options=(emptydirs)
-
-#prepare() {
-# cd "${srcdir}"
-# tar xzf control.tar.gz
-#}
-
-#pkgver() {
-# grep -i "Version" "${srcdir}"/control | cut -d ' ' -f 2
-#}
+md5sums_i686=('661f3cdd54908c06f59d1e6adb537a42')
+md5sums_x86_64=('e3b069e25d1e693a34db88b66ccffc8c')
package() {
if [[ "${CARCH}" = 'i686' ]]; then
@@ -35,8 +28,4 @@ if [[ "${CARCH}" = 'x86_64' ]]; then
bsdtar xf "${pkgname}-v${pkgver}-${_channel}-amd64.deb"
fi
bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
-
-# install -d $pkgdir/usr/bin
-# ln -s /usr/bin/polo-gtk $pkgdir/usr/bin/polo
-# rm $pkgdir/usr/bin/polo-uninstall
}