summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-07-03 23:56:44 +0200
committerFabioLolix2017-07-03 23:56:44 +0200
commit7beb140db5841181356e476b59135911ab5beb21 (patch)
treef6e9b709acbae9bc6c09543b4d79ebb41ec0e307
downloadaur-7beb140db5841181356e476b59135911ab5beb21.tar.gz
initial release, version 17.7 beta.8
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD37
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21adeadb07ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = polo-donation-plugins
+ pkgdesc = Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc.
+ pkgver = 17.7
+ pkgrel = 1
+ url = http://www.teejeetech.in/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = polo
+ provides = polo-donations-plugins
+ conflicts = polo-donations-plugins
+ source_i686 = local://polo-donation-plugins-v17.7-beta.8-i386.deb
+ md5sums_i686 = 61df636b4dc16f3196cf54d519f31d6a
+ source_x86_64 = local://polo-donation-plugins-v17.7-beta.8-amd64.deb
+ md5sums_x86_64 = 5133b8020b51e1b2d4154fd3f4f2d328
+
+pkgname = polo-donation-plugins
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a2b9f39f612a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+*.gz
+*.xz
+*.zip
+*.tar*
+*.tgz
+*.bz2
+*.deb
+*.rpm
+*.run
+pkg
+src
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d485d7af3c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# https://github.com/FabioLolix
+
+pkgname=polo-donation-plugins
+_betaver=beta.8
+pkgver=17.7
+pkgrel=1
+pkgdesc="Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc."
+arch=('i686' 'x86_64')
+url="http://www.teejeetech.in/"
+license=('GPL2')
+depends=('polo')
+provides=('polo-donations-plugins')
+conflicts=('polo-donations-plugins')
+source_i686=("local://"$pkgname"-v${pkgver}-"$_betaver"-i386.deb")
+source_x86_64=("local://"$pkgname"-v${pkgver}-"$_betaver"-amd64.deb")
+md5sums_i686=('61df636b4dc16f3196cf54d519f31d6a')
+md5sums_x86_64=('5133b8020b51e1b2d4154fd3f4f2d328')
+
+prepare() {
+ cd "${srcdir}"
+ tar xzf control.tar.gz
+}
+
+pkgver() {
+ grep -i "Version" "${srcdir}"/control | cut -d ' ' -f 2
+}
+
+package() {
+if [[ "${CARCH}" = 'i686' ]]; then
+ bsdtar -xf "$pkgname"-v${pkgver}-"$_betaver"-i386.deb
+ fi
+if [[ "${CARCH}" = 'x86_64' ]]; then
+ bsdtar -xf "$pkgname"-v${pkgver}-"$_betaver"-amd64.deb
+ fi
+ bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+}