summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-06-16 11:37:28 +0200
committerFabioLolix2018-06-16 11:37:28 +0200
commitb5c5db9a3004dd06f8c073f218e6e0a4d30dbec9 (patch)
treeb439c9cf0f69d16dddf4e544a338d2bb95faa15e
parent05e165f166a656796d34be67bf64fb46a5692543 (diff)
downloadaur-b5c5db9a3004dd06f8c073f218e6e0a4d30dbec9.tar.gz
various changes
-rwxr-xr-x.SRCINFO8
-rwxr-xr-xPKGBUILD26
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22066fd411b1..f862eb020c7d 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = polo-donation-plugins
pkgdesc = Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc.
pkgver = 18.2
- pkgrel = 1
- url = http://www.teejeetech.in/
+ pkgrel = 2
+ url = https://github.com/teejee2008/polo/wiki/Donation-Features
arch = i686
arch = x86_64
depends = polo
- depends = youtube-dl
- depends = pngcrush
- depends = ghostscript
- depends = pdftk-bin
provides = polo-donations-plugins
conflicts = polo-donations-plugins
source_i686 = local://polo-donation-plugins-v18.2-i386.deb
diff --git a/PKGBUILD b/PKGBUILD
index 87a824351f68..a71223866770 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
-# https://github.com/FabioLolix
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=polo-donation-plugins
_channel=beta.10
pkgver=18.2
-pkgrel=1
+pkgrel=2
pkgdesc="Complimentary package for users who have donated to Polo or contributed in other ways such as translations, code changes, etc."
arch=('i686' 'x86_64')
-url="http://www.teejeetech.in/"
-depends=('polo'
- 'youtube-dl'
- 'pngcrush'
- 'ghostscript'
- 'pdftk-bin' )
+url="https://github.com/teejee2008/polo/wiki/Donation-Features"
+depends=('polo')
+optdepednds=(
+ 'clamav: for ClamAV plugin'
+ 'ghostscript: for PDF plugin'
+ 'pdftk: for PDF plugin'
+ 'pdftk-bin: for PDF plugin'
+ 'pngcrush: for Image plugin'
+ 'qemu: for ISO plugin'
+ 'samba: for ISO plugin (kvm -smb)'
+ 'youtube-dl: for Video download plugin'
+)
provides=('polo-donations-plugins')
conflicts=('polo-donations-plugins')
source_i686=("local://${pkgname}-v${pkgver}-i386.deb")
@@ -28,4 +33,7 @@ if [[ "${CARCH}" = 'x86_64' ]]; then
bsdtar xf "${pkgname}-v${pkgver}-amd64.deb"
fi
bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -s /usr/bin/qemu-system-x86_64 ${pkgdir}/usr/bin/kvm
}