summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLolix2019-06-30 23:46:49 +0200
committerLolix2019-06-30 23:46:49 +0200
commit958d0d021353b0461f2c7028a363ab0a3465566f (patch)
treeb675ce540d710b106f47c7a4375afb963063b64f
parente596bc533ecfa2c9d2ec869e9f58b2dc0cfb0397 (diff)
downloadaur-958d0d021353b0461f2c7028a363ab0a3465566f.tar.gz
revision
-rw-r--r--.SRCINFO7
-rw-r--r--0001-fix-build.patch27
-rw-r--r--PKGBUILD29
3 files changed, 40 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea04810daadb..d1157504dd14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = polo-git
pkgdesc = A modern, light-weight GTK file manager for Linux, currently in beta
- pkgver = 18.8.beta.r0.g302c071
+ pkgver = 18.8.beta.r28.g173d4e6
pkgrel = 1
url = https://teejee2008.github.io/polo/
arch = i686
@@ -26,11 +26,8 @@ pkgbase = polo-git
optdepends = polo-donation-plugins
provides = polo
conflicts = polo
- conflicts = polo-bin
- source = polo-git::git+https://github.com/teejee2008/polo.git
- source = 0001-Re-add-support-for-vte291-0.52.patch
+ source = git+https://github.com/teejee2008/polo.git
sha256sums = SKIP
- sha256sums = 4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f
pkgname = polo-git
diff --git a/0001-fix-build.patch b/0001-fix-build.patch
new file mode 100644
index 000000000000..c080c14b21f7
--- /dev/null
+++ b/0001-fix-build.patch
@@ -0,0 +1,27 @@
+From 94d710c2723f6fd485d7747bd37227d5cd18a27c Mon Sep 17 00:00:00 2001
+From: FabioLolix <fabio.lolix@gmail.com>
+Date: Mon, 17 Sep 2018 23:14:55 +0200
+Subject: [PATCH] fix build
+
+---
+ src/makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/makefile b/src/makefile
+index d1ec28b..1d3bd4d 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -16,9 +16,8 @@ app_fullname='Polo'
+
+ vte_symbol = -D VTE_291
+ vte_version=$(shell { (pkg-config --modversion vte-2.91 | cut -d. -f 2,3); } )
+-vala_version=$(shell { (valac --version | cut -d. -f 2); } )
+
+-ifeq ($(shell { test ${vala_version} -lt 42 ; echo $$? ; } ), 0)
++ifeq ($(shell { test ${vte_version} -lt 52.2 ; echo $$? ; } ), 0)
+ vte_symbol=$(shell echo '-D VTE_291_OLD')
+ else
+ vte_symbol=$(shell echo '-D VTE_291')
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 11e9ecddd9db..00dd0ae935b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=polo-git
pkgrel=1
-pkgver=18.8.beta.r0.g302c071
+pkgver=18.8.beta.r28.g173d4e6
pkgdesc="A modern, light-weight GTK file manager for Linux, currently in beta"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="https://teejee2008.github.io/polo/"
-license=('GPL2')
-depends=('gtk3' 'libgee' 'libsoup' 'vte3' 'rsync' 'gvfs' 'p7zip')
+license=(GPL2)
+depends=(gtk3 libgee libsoup vte3 rsync gvfs p7zip)
makedepends=(vala git)
optdepends=('mediainfo: read media properties from audio and video files'
'fish: terminal shell'
@@ -18,30 +18,23 @@ optdepends=('mediainfo: read media properties from audio and video files'
'gnome-disk-utility'
'lzop'
'polo-donation-plugins')
-provides=('polo')
-conflicts=('polo' 'polo-bin')
-source=("${pkgname}::git+https://github.com/teejee2008/polo.git"
- '0001-Re-add-support-for-vte291-0.52.patch')
-sha256sums=('SKIP'
- '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f')
+provides=(polo)
+conflicts=(polo)
+source=("git+https://github.com/teejee2008/polo.git")
+sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "$srcdir/${pkgname/-git/}"
git describe --long --tags | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${pkgname}"
- patch -Np1 -i ../0001-Re-add-support-for-vte291-0.52.patch
-}
-
build() {
- cd "${pkgname}"
+ cd "$srcdir/${pkgname/-git/}"
make
}
package() {
- cd "${pkgname}"
+ cd "$srcdir/${pkgname/-git/}"
make DESTDIR="${pkgdir}" install
ln -s /usr/bin/polo-gtk "${pkgdir}"/usr/bin/polo