summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-08-13 01:56:44 +0200
committerFabioLolix2018-08-13 01:56:44 +0200
commite596bc533ecfa2c9d2ec869e9f58b2dc0cfb0397 (patch)
tree44f8f862ccf69b0aac85dfac27f35b69a1d7cd05
parent96c7af921710b3315fd73d040b9360c9318ec6d7 (diff)
downloadaur-e596bc533ecfa2c9d2ec869e9f58b2dc0cfb0397.tar.gz
Fix build
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Fixed-build-with-recent-vala-version.patch25
-rw-r--r--0001-Re-add-support-for-vte291-0.52.patch25
-rw-r--r--PKGBUILD11
4 files changed, 33 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e6dc3d23211..ea04810daadb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = polo-git
pkgdesc = A modern, light-weight GTK file manager for Linux, currently in beta
- pkgver = 18.6.beta.r0.g1b7faa1
+ pkgver = 18.8.beta.r0.g302c071
pkgrel = 1
url = https://teejee2008.github.io/polo/
arch = i686
arch = x86_64
license = GPL2
makedepends = vala
- makedepends = chrpath
makedepends = git
depends = gtk3
depends = libgee
@@ -29,9 +28,9 @@ pkgbase = polo-git
conflicts = polo
conflicts = polo-bin
source = polo-git::git+https://github.com/teejee2008/polo.git
- source = 0001-Fixed-build-with-recent-vala-version.patch
+ source = 0001-Re-add-support-for-vte291-0.52.patch
sha256sums = SKIP
- sha256sums = 97d78f7879eb913dc4b9574e6854553e956f5a883beef2335887d1d12061d0b2
+ sha256sums = 4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f
pkgname = polo-git
diff --git a/0001-Fixed-build-with-recent-vala-version.patch b/0001-Fixed-build-with-recent-vala-version.patch
deleted file mode 100644
index 63a19ac24b48..000000000000
--- a/0001-Fixed-build-with-recent-vala-version.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9ab01270ce389780e3eecb84935c003440befc5a Mon Sep 17 00:00:00 2001
-From: FabioLolix <fabio.lolix@gmail.com>
-Date: Sat, 16 Jun 2018 09:49:13 +0200
-Subject: [PATCH] Fixed build with recent vala version
-
----
- src/Gtk/TermBox.vala | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Gtk/TermBox.vala b/src/Gtk/TermBox.vala
-index a3ed31a..af5d4d1 100644
---- a/src/Gtk/TermBox.vala
-+++ b/src/Gtk/TermBox.vala
-@@ -249,7 +249,7 @@ public class TermBox : Gtk.Box {
- cmd = "%s\n".printf(cmd);
- }
-
-- term.feed_child(cmd, -1);
-+ term.feed_child(cmd.to_utf8());
- }
-
- public void refresh(){
---
-2.17.1
-
diff --git a/0001-Re-add-support-for-vte291-0.52.patch b/0001-Re-add-support-for-vte291-0.52.patch
new file mode 100644
index 000000000000..649704608c31
--- /dev/null
+++ b/0001-Re-add-support-for-vte291-0.52.patch
@@ -0,0 +1,25 @@
+From d73eda26423ef9730eded03c78c636bebe971948 Mon Sep 17 00:00:00 2001
+From: FabioLolix <fabio.lolix@gmail.com>
+Date: Mon, 13 Aug 2018 01:44:37 +0200
+Subject: [PATCH] Re-add support for vte291 >0.52
+
+---
+ src/Gtk/TermBox.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Gtk/TermBox.vala b/src/Gtk/TermBox.vala
+index da5d3a0..0c7b37c 100644
+--- a/src/Gtk/TermBox.vala
++++ b/src/Gtk/TermBox.vala
+@@ -255,7 +255,7 @@ public class TermBox : Gtk.Box {
+
+ #else
+
+- term.feed_child(cmd, -1);
++ term.feed_child(cmd.to_utf8());
+
+ #endif
+ }
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index e3e8c3e9aed0..11e9ecddd9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=polo-git
pkgrel=1
-pkgver=18.6.beta.r0.g1b7faa1
+pkgver=18.8.beta.r0.g302c071
pkgdesc="A modern, light-weight GTK file manager for Linux, currently in beta"
arch=('i686' 'x86_64')
url="https://teejee2008.github.io/polo/"
license=('GPL2')
depends=('gtk3' 'libgee' 'libsoup' 'vte3' 'rsync' 'gvfs' 'p7zip')
-makedepends=('vala' 'chrpath' 'git')
+makedepends=(vala git)
optdepends=('mediainfo: read media properties from audio and video files'
'fish: terminal shell'
'perl-image-exiftool: read EXIF properties from JPG/TIFF/PNG/PDF files'
@@ -21,9 +21,9 @@ optdepends=('mediainfo: read media properties from audio and video files'
provides=('polo')
conflicts=('polo' 'polo-bin')
source=("${pkgname}::git+https://github.com/teejee2008/polo.git"
- '0001-Fixed-build-with-recent-vala-version.patch')
+ '0001-Re-add-support-for-vte291-0.52.patch')
sha256sums=('SKIP'
- '97d78f7879eb913dc4b9574e6854553e956f5a883beef2335887d1d12061d0b2')
+ '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f')
pkgver() {
cd "${pkgname}"
@@ -32,7 +32,7 @@ pkgver() {
prepare() {
cd "${pkgname}"
- patch -Np1 -i ../0001-Fixed-build-with-recent-vala-version.patch
+ patch -Np1 -i ../0001-Re-add-support-for-vte291-0.52.patch
}
build() {
@@ -44,7 +44,6 @@ package() {
cd "${pkgname}"
make DESTDIR="${pkgdir}" install
- chrpath --delete "${pkgdir}"/usr/bin/polo-gtk
ln -s /usr/bin/polo-gtk "${pkgdir}"/usr/bin/polo
rm "${pkgdir}"/usr/bin/polo-uninstall
}