summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2015-06-09 16:55:48 +0200
committerGilrain2015-06-09 16:55:48 +0200
commit1e26f2276cc7fe10b1d5df25460e1571adb11a77 (patch)
tree6e00beaf4aa2e7c0c0a68d716b09ec8b7cc8e855
downloadaur-1e26f2276cc7fe10b1d5df25460e1571adb11a77.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD46
-rw-r--r--changelog53
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0a20e3ad1f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = pology
+ pkgdesc = A framework for custom processing of PO files.
+ pkgver = 0.12
+ pkgrel = 1
+ url = http://techbase.kde.org/Localization/Tools/Pology
+ changelog = changelog
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = libxml2
+ makedepends = docbook-xsl
+ makedepends = epydoc
+ makedepends = python2-pygments
+ depends = python2
+ depends = gettext
+ optdepends = python2-dbus: to communicate with external applications
+ optdepends = python2-pyenchant: spell checking functionality (needs a dictionary)
+ optdepends = hunspell-lang: a spell-checking dictionary for your language(s)
+ optdepends = aspell-lang: a spell-checking dictionary for your language(s)
+ optdepends = ispell-lang: a spell-checking dictionary for your language(s)
+ optdepends = languagetool: used by the check-grammar sieve
+ optdepends = apertium: used by the pomtrans script
+ optdepends = git: for processing files under version control
+ optdepends = subversion: for processing files under version control
+ conflicts = pology-svn
+ options = !makeflags
+ source = http://pology.nedohodnik.net/release/pology-0.12.tar.bz2
+ sha256sums = 33fd75b7214fc70882df128b5651d4870cb7d6cc73ca27c5517b4686976de5de
+
+pkgname = pology
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0e617aa49d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+
+pkgname=pology
+pkgver=0.12
+pkgrel=1
+pkgdesc='A framework for custom processing of PO files.'
+arch=('any')
+license=('GPL3')
+url='http://techbase.kde.org/Localization/Tools/Pology'
+depends=('python2' 'gettext')
+makedepends=('cmake' 'libxml2' 'docbook-xsl' 'epydoc' 'python2-pygments')
+options=(!makeflags)
+optdepends=('python2-dbus: to communicate with external applications'
+ 'python2-pyenchant: spell checking functionality (needs a dictionary)'
+ 'hunspell-lang: a spell-checking dictionary for your language(s)'
+ 'aspell-lang: a spell-checking dictionary for your language(s)'
+ 'ispell-lang: a spell-checking dictionary for your language(s)'
+ 'languagetool: used by the check-grammar sieve'
+ 'apertium: used by the pomtrans script'
+ 'git: for processing files under version control'
+ 'subversion: for processing files under version control')
+conflicts=('pology-svn')
+changelog=changelog
+source=(http://pology.nedohodnik.net/release/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('33fd75b7214fc70882df128b5651d4870cb7d6cc73ca27c5517b4686976de5de')
+
+prepare() {
+ sed -i -e 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' $(find ${srcdir} -name '*.py')
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DDOCBOOK_XSL_DIR=/usr/share/xml/docbook/xsl-stylesheets-1.78.1/
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -d ${pkgdir}/usr/share/apps/katepart/syntax
+ ln -s /usr/share/pology/syntax/kate/synder.xml ${pkgdir}/usr/share/apps/katepart/syntax/synder.xml
+
+ install -d ${pkgdir}/etc/bash_completion.d
+ ln -s /usr/share/pology/completion/bash/pology ${pkgdir}/etc/bash_completion.d/pology
+}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..d8700575f38f
--- /dev/null
+++ b/changelog
@@ -0,0 +1,53 @@
+2014-08-02 Gilrain <pierre.buard+aur gmail com>
+ * 0.12-1 :
+ new upstream release:
+ New functionality:
+ * check-rules sieve: New parameter 'byrule' to list failed messages
+ at the end of processing sorted by rule identifier.
+ * new unfuzzy-qtclass-only sieve: Unfuzzy messages which were
+ fuzzied due to C++ class name change in code, in catalogs
+ derived by conversion from Qt Linguist translation files.
+ * posummit: New field to set the precedence of summit subdirectories
+ (S.subdir_precedence), so that branch catalogs existing in
+ two or more branch subdirectories are always located in
+ the higher priority summit subdirectory.
+ When processing summit catalogs with some precedence set,
+ the order of processing is also following the precedence,
+ instead of being alphabetical by path throughout.
+ * Syntax highlighting for code snippets in the user manual.
+ * Updated language support (spelling, rules, etc):
+ Catalan, French, Galician, Norwegian, Serbian, Spanish.
+ * Updated project-specific support: KDE.
+
+ Modified functionality:
+ * stats sieve: File with list of incomplete catalogs
+ (when setting 'incompfile' parameter ) is always written,
+ even if all catalogs are complete, i.e. empty list file is produced.
+ This prevents an old list file appearing as the new one.
+ * posummit: When branch catalogs without expected corresponding
+ summit catalogs are detected (on merge and scatter), instead of
+ error a warning is issued. It has been seen in practice that
+ higher attention demanded by error was more trouble than worth.
+ Such branch catalogs are then skipped during the operation.
+
+ Fixed bugs:
+ * Word wrapping of message fields when writing catalogs was wrong
+ in some cases when visual and character word lengths were different
+ (e.g. CJK languages). This could have resulted in corrupted catalogs.
+ * stats sieve: Heuristics for splitting word count from fuzzy messages
+ into translated/untranslated (when 'ondiff' parameter is issued)
+ will no longer cause negative additions.
+ * More detailed licensing information throughout.
+ * Adapted VCS handling for Subversion 1.7.
+ python2-pygments added to makedepends
+
+2013-04-19 Gilrain <pierre.buard+aur gmail com>
+ * 0.11-3 :
+ updated to docbook-xsl 1.78.1
+ PKGBUILD conforms to pacman 4.1 guidelines
+
+2013-02-09 Gilrain <pierre.buard+aur gmail com>
+ * 0.11-2 :
+ added changelog.
+ updated to docbook-xsl 1.78.0
+ expanded and reworked dependencies.