summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGina White2016-10-12 18:57:26 -0700
committerGina White2016-10-12 18:57:26 -0700
commite6fed3f96790a980d861a7233f58643edf487e61 (patch)
tree955f9c00bdacbdbc4df6878ebe086adb988a34cf
parent4f8defd0295e1602f63e8bb07605b417dc290e63 (diff)
downloadaur-e6fed3f96790a980d861a7233f58643edf487e61.tar.gz
more dependencies
added dependencies on gcc and on libunistring. also hacked together a way to test dependencies inside a rkt container.
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile5
-rw-r--r--PKGBUILD5
-rwxr-xr-xtest_in_rkt.sh18
4 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed5531b1c77e..90db388546f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = poltroon
arch = x86_64
arch = i686
license = MIT
- makedepends = go>=1.7 make go-bindata>=3.0.7
+ makedepends = go>=1.7 make go-bindata>=3.0.7 libunistring>=0.9.6-2 gcc
depends = pacman
options = !strip
options = !emptydirs
diff --git a/Makefile b/Makefile
index 73a15b457f73..59ec6d06624b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,5 @@
+ROOT_DIR:=$(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))
+
all: .SRCINFO verify
.SRCINFO: PKGBUILD
@@ -14,5 +16,8 @@ verify:
makepkg -f
namcap PKGBUILD
namcap *.pkg.tar.xz
+ @echo "precheck succeeded. Run the final check with:"
+ @echo ""
+ @echo "sudo rkt --net=host --dns=host --insecure-options=image run docker://base/archlinux --interactive=true --exec /pkg/test_in_rkt.sh --volume pkg,kind=host,source=$(ROOT_DIR) --mount volume=pkg,target=/pkg"
.PHONY: verify clean all
diff --git a/PKGBUILD b/PKGBUILD
index 8282c03d36bd..b4173107aa7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=poltroon
pkgver=0.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="An AUR agent for that prioritizes managing batches of packages."
arch=('x86_64' 'i686')
url="https://github.com/ginabythebay/poltroon"
license=('MIT')
depends=('pacman')
-makedepends=('go>=1.7 make go-bindata>=3.0.7')
+makedepends=('go>=1.7 make go-bindata>=3.0.7 libunistring>=0.9.6-2 gcc')
options=('!strip' '!emptydirs')
source=("https://github.com/ginabythebay/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('5ee3825234c0f6d6daff320a2a49df9490de1e804b50aeea309764f1228b03a5')
@@ -17,6 +17,7 @@ _gourl=github.com/ginabythebay/poltroon
build() {
mkdir -p "$srcdir/go/src/github.com/ginabythebay"
+ rm -rf "$srcdir/go/src/$_gourl" # just in case we run this twice
mv "$srcdir/$pkgname-$pkgver" "$srcdir/go/src/$_gourl"
export GOPATH="$srcdir/go"
diff --git a/test_in_rkt.sh b/test_in_rkt.sh
new file mode 100755
index 000000000000..c1e2a680a2f4
--- /dev/null
+++ b/test_in_rkt.sh
@@ -0,0 +1,18 @@
+#!/bin/bash
+
+set -ev
+
+rundir=$HOME/pkg
+
+mkdir -p $rundir
+
+cp -R /pkg/* $rundir/
+
+# sync dbs
+pacman --sync --refresh
+
+# install reasonbly fresh keyring so we can trust current maintainers
+pacman --noconfirm --sync archlinux-keyring
+
+cd $rundir
+makepkg -f --asroot --syncdeps --noconfirm