summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGina White2016-10-08 15:30:00 -0700
committerGina White2016-10-08 15:30:00 -0700
commitf303750f4dd9ada11531d4dbba7c48fbd0d688dc (patch)
treefe595b3c9de80422ed967203f1a81bc51a81df6e
parentf7c3798325594ecf97389392e80fc57ebe68ea00 (diff)
downloadaur-f303750f4dd9ada11531d4dbba7c48fbd0d688dc.tar.gz
Makefile and .gitignore
Main thing is updating .SRCINFO and sanity checks.
-rw-r--r--.gitignore8
-rw-r--r--Makefile18
2 files changed, 26 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5308bd98d923
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# emacs
+*~
+
+# files and directories that makepkg leaves around
+pkg/
+src/
+poltroon-*.pkg.tar.xz
+v*.tar.gz \ No newline at end of file
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ad52d6782949
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+all: .SRCINFO verify
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+# These can all be created during verify
+clean:
+ rm -rf pkg
+ rm -rf src
+ rm poltroon-*.pkg.tar.xz
+ rm v*.tar.gz
+
+verify:
+ makepkg -f
+ namcap PKGBUILD
+ namcap *.pkg.tar.xz
+
+.PHONY: verify clean all