summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Ford2020-10-13 14:39:16 +0100
committerOliver Ford2020-10-13 14:39:16 +0100
commit1e514a38c0ceaa7761833d95ef211c57036ac8f1 (patch)
tree7429f140925fa018e2d4b2a8722d6b6289d5774f
downloadaur-1e514a38c0ceaa7761833d95ef211c57036ac8f1.tar.gz
Package github.com/Jvanrhijn/polybar-spotify
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8697dff70285
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = polybar-spotify
+ pkgdesc = A tool to generate custom Iosevka fonts from a configuration file
+ pkgver = 20200619_b5c59238a17180affae5232c234175524a17d1c4
+ pkgrel = 1
+ url = https://github.com/Jvanrhijn/polybar-spotify
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-dbus
+ depends = spotify
+ source = https://github.com/Jvanrhijn/polybar-spotify/archive/b5c59238a17180affae5232c234175524a17d1c4.zip
+ md5sums = 815b25c418611c58370733479bd2b504
+
+pkgname = polybar-spotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7cd8476615e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Oliver Ford <dev.aur@ojford.com>
+# shellcheck disable=SC2034,SC2154
+pkgname=polybar-spotify
+pkgver=20200619_b5c59238a17180affae5232c234175524a17d1c4
+pkgrel=1
+pkgdesc='A tool to generate custom Iosevka fonts from a configuration file'
+url='https://github.com/Jvanrhijn/polybar-spotify'
+license=('MIT')
+ref="${pkgver:9}"
+source=("${url}/archive/${ref}.zip")
+md5sums=('815b25c418611c58370733479bd2b504')
+arch=('any')
+depends=(
+ 'python'
+ 'python-dbus'
+ 'spotify'
+)
+optdepends=(
+)
+conflicts=(
+)
+
+package() {
+ set -e
+ cd "$pkgname-$ref"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m755 "./spotify_status.py" "$pkgdir/usr/bin/$pkgname"
+}